Untitled

mail@pastecode.io avatar
unknown
plain_text
a year ago
2.5 kB
0
Indexable
Never
Процедура ОбработкаПроведения(Отказ, РежимПроведения)

	ПериодРегистрации = НачалоМесяца(Дата);
	
	// регистр ОсновныеНачисления	
	Движения.ОсновныеНачисления.Записывать = Истина;
	
	ВидРасчетаСверхурочные = ПланыВидовРасчета.ОсновныеНачисления.Сверхурочные;
	НачалоБазовогоПериода = ДобавитьМесяц(ПериодРегистрации, -1);
	КонецБазовогоПериода = КонецМесяца(НачалоБазовогоПериода);
	
	Для Каждого ТекСтрокаОсновныеНачисления Из ОсновныеНачисления Цикл
		Движение = Движения.ОсновныеНачисления.Добавить();
		Движение.Сторно = Ложь;
		Движение.ВидРасчета = ТекСтрокаОсновныеНачисления.ВидРасчета;
		Движение.ПериодДействияНачало = ТекСтрокаОсновныеНачисления.ДатаНачала;
		Движение.ПериодДействияКонец = ТекСтрокаОсновныеНачисления.ДатаОкончания;
		Движение.ПериодРегистрации = ПериодРегистрации;
		Движение.Сотрудник = ТекСтрокаОсновныеНачисления.Сотрудник;
		Движение.Подразделение = ТекСтрокаОсновныеНачисления.Подразделение;
		
		Если ТекСтрокаОсновныеНачисления.ВидРасчета = ВидРасчетаСверхурочные Тогда
			Движение.БазовыйПериодНачало = НачалоБазовогоПериода;
			Движение.БазовыйПериодКонец = КонецБазовогоПериода;
		КонецЕсли;
		
	КонецЦикла;

	// Запись рабочих наборов записей
	Движения.Записать();
	
	// Окончательный расчет данных в регистрах
	Расчет.РассчитатьНачисления(Ссылка, Движения.ОсновныеНачисления, Отказ);

КонецПроцедуры