ParOuImpar

mail@pastecode.io avatar
unknown
plain_text
2 years ago
725 B
6
Indexable
Never
programa {
 
	inclua biblioteca Util
 
  funcao inicio() {
 
    inteiro jogador1 
    inteiro jogador2
 
    cadeia opcao
 
    escreva ("Jogador 1, par ou impar?\n")
    leia (opcao)
 
    escreva ("Jogador 1, insira o número de dedos (0-5)\n")
    leia (jogador1)
 
    jogador2 = Util.sorteia (0, 5)
    escreva ("Jogador 2 escolheu ", jogador2, "\n")
 
	inteiro soma = jogador1 + jogador2
 
	se ( opcao == "par" e soma % 2 == 0 ) //PAR, e se é PAR o jogador1 vence
	{
		escreva ("JOGADOR 1 VENCEU!!")
	}
	senao se ( opcao == "impar" e soma % 2 == 1){ //IMPAR
		escreva ("JOGADOR 1 VENCEU!!")
	}
	senao {
		escreva ("JOGADOR 2 VENCEU!!!")
	}
 
    escreva("\nFIM DE JOGO")
 
  }
 
}