Untitled

mail@pastecode.io avatar
unknown
assembly_x86
a year ago
1.7 kB
1
Indexable
Never
Algoritmo ControlDeGastosPersonales
	Definir gastos_fijos Como Real;
	Definir gastos_variables Como Real;
	Definir dp Como Real;
	Definir ingresos Como Real;
	Definir meta_ahorro Como Real;
	Definir total_gastos Como Real;
	Definir presupuesto_disponible Como Real;
	Definir max_ahorro Como Real;
	Definir ahorro_actual Como Real;
	Definir i Como Entero;
	Definir j Como Entero;
	
	Escribir "Control de Gastos Personales";
	Escribir "";
	
	Escribir "Ingresos:";
	Leer ingresos;
	
	Para i <- 1 Hasta 5
		Escribir "Gasto fijo ", i, ":";
		Leer gastos_fijos;
	Fin Para
	
	Para i <- 1 Hasta 5
		Escribir "Gasto variable ", i, ":";
		Leer gastos_variables;
	Fin Para
	
	Escribir "Meta de Ahorro:";
	Leer meta_ahorro;
	
	total_gastos <- 0;
	Para i <- 1 Hasta 5
		total_gastos <- total_gastos + gastos_fijos;
	Fin Para
	
	Para i <- 1 Hasta 5
		total_gastos <- total_gastos + gastos_variables;
	Fin Para
	
	presupuesto_disponible <- ingresos - total_gastos;
	
	Si presupuesto_disponible < 0 Entonces
		Escribir "¡Cuidado! Tus gastos superan tus ingresos.";
	Sino
		i <- 1;
		Mientras i <= presupuesto_disponible
			max_ahorro <- 0;
			j <- 1;
			Mientras j <= 5
				Si gastos_variables <= i Entonces
					ahorro_actual <- dp + gastos_variables;
					Si ahorro_actual > max_ahorro Entonces
						max_ahorro <- ahorro_actual;
					Fin Si
				Fin Si
				j <- j + 1;
			Fin Mientras
			dp <- max_ahorro;
			i <- i + 1;
		Fin Mientras
		
		Si dp >= meta_ahorro Entonces
			Escribir "¡Felicidades! Has alcanzado tu meta de ahorro.";
		Sino
			Escribir "No has alcanzado tu meta de ahorro.";
		Fin Si
		
		Escribir "El ahorro máximo alcanzado es: ", dp;
	Fin Si
FinAlgoritmo