Untitled

mail@pastecode.io avatar
unknown
plain_text
3 years ago
2.2 kB
2
Indexable
Never
Algoritmo “cadastroCelular”

Tipo
    produto = registro
    codigo: inteiro
    nome: Vetor[1..30] de caractere
    quantidade: inteiro
    valor: real
    espcor: Vetor[1..30] de caractere
    esptela: real
    memoriarom: inteiro
    memoriaram: inteiro
Fimregistro
Var
    Lista_prod: Vetor [1..100] de produto
    I: inteiro
    acha: logico
    resp: vetor[1..3] de caractere
Inicio
    para i de 1 ate 100 passo 1 faca
        Escreva(“Digite o código do produto “ ,i, “:”)
            Leia (lista_prod[i]. codigo)
        Escreva(“Insira o valor do produto “ ,i, “:”)
            Leia(lista_prod[i].valor)
        Escreva(“Digite o nome do produto “ ,i, “:”)
            Leia(lista_prod[i].nome)
        Escreva(“Digite a quantidade de produtos “ ,i, “:”)
        Leia(lista_prod[i].quantidade)
        Escreva(“Digite a cor do aparelho” , i, “:”)
            Leia(lista_prod[i].espcor)
        Escreva(“Digite o tamanho da tela do aparelho”, i, “:”)
            Leia(lista_prod[i].esptela)
        Escreva(“Digite a quantidade de memória ROM”, i, “:”)
            Leia(lista_prod[i].memoriarom)
        Escreva(“Digite a quantidade de memória RAM”, i, “:”)
            Leia(lista_prod[i].memoriaram)
Fimpara

resp <- “sim”
Enquanto (resp = “sim”) faca
        Escreva(“Informe o código a ser pesquisado:”)
        Leia(lista_prod.codigo)
        i <- 1
    acha <- falso
    Enquanto (i < = 100) e (acha= falso) faça
        Se (lista_prod[i].codigo = codigo) então
        acha <- verdadeiro
    Senão
        i <- i + 1
    fim_se
fim_enquanto

Se (acha = verdadeiro) então
    Escreva(“O preço é:”, lista_prod[i].valor)
    Escreva(“O nome do produto é:”, lista_prod[i].nome)
    Escreva(“O estoque do produto está em:”, lista_prod[i].quantidade)
    Escreva(“A quantidade de memória RAM é:”, lista_prod[i].memoriaram)
    Escreva(“A quantidade de memória ROM é:”, lista_prod[i].memoriarom)
Senão
    Escreva(“Não há produto com o código informado”)
fim_se
    Escreva(“Deseja continuar a pesquisa?”)
Leia(resp)

fim_enquanto
Fim