Untitled

mail@pastecode.io avatar
unknown
plain_text
2 years ago
105 kB
1
Indexable
Never
failed: [localhost] (item=nodegit) => {"ansible_loop_var": "item", "changed": true, "cmd": ["npm", "install", "-g", "nodegit"], "delta": "0:02:17.476004", "end": "2021-09-02 13:02:24.121686", "item": "nodegit", "msg": "non-zero return code", "rc": 1, "start": "2021-09-02 13:00:06.645682", "stderr": "npm WARN deprecated har-validator@5.1.5: this library is no longer supported\nnpm WARN deprecated uuid@3.4.0: Please upgrade  to version 7 or higher.  Older versions may use Math.random() in certain circumstances, which is known to be problematic.  See https://v8.dev/blog/math-random for details.\nnpm WARN deprecated request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142\nnpm WARN deprecated node-pre-gyp@0.13.0: Please upgrade to @mapbox/node-pre-gyp: the non-scoped node-pre-gyp package is deprecated and only the @mapbox scoped package will recieve updates in the future\nnpm ERR! code 1\nnpm ERR! path /usr/local/lib/node_modules/nodegit\nnpm ERR! command failed\nnpm ERR! command sh -c node lifecycleScripts/preinstall && node lifecycleScripts/install\nnpm ERR! [nodegit] Running pre-install script\nnpm ERR! [nodegit] Running install script\nnpm ERR! SOLINK_MODULE(target) Release/acquireOpenSSL.node\nnpm ERR! ACTION binding_gyp_configureLibssh2_target_configure .\nnpm ERR! [nodegit] Configuring libssh2.\nnpm ERR! SOLINK_MODULE(target) Release/configureLibssh2.node\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/allocators/stdalloc.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/commit.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/alloc.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/annotated_commit.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/apply.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/attr_file.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/attr.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/attrcache.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/blame_git.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/blame.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/blob.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/branch.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/buf_text.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/buffer.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/cache.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/checkout.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/cherrypick.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/clone.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/commit_list.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/config_cache.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/config_entries.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/config_file.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/config_mem.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/config_parse.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/config_snapshot.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/config.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/crlf.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/date.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/delta.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/diff_driver.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/diff_file.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/diff_generate.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/diff_parse.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/diff_print.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/diff_stats.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/diff_tform.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/diff_xdiff.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/diff.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/errors.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/fetch.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/fetchhead.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/filebuf.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/futils.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/filter.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/global.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/graph.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/hash.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/hash/sha1/sha1dc/sha1.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/hash/sha1/sha1dc/ubc_check.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/hash/sha1/collisiondetect.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/hashsig.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/ident.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/idxmap.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/ignore.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/index.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/indexer.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/iterator.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/mailmap.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/merge_driver.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/merge_file.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/merge.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/message.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/mwindow.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/net.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/netops.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/notes.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/object_api.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/object.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/odb_loose.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/odb_mempack.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/odb_pack.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/odb.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/offmap.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/oid.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/oidarray.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/oidmap.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/streams/mbedtls.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/streams/openssl.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/streams/registry.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/pack-objects.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/pack.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/parse.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/patch_generate.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/patch_parse.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/patch.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/path.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/pathspec.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/pool.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/posix.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/pqueue.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/proxy.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/push.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/reader.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/rebase.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/refdb_fs.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/refdb.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/reflog.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/refs.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/refspec.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/regexp.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/remote.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/repository.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/reset.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/revert.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/revparse.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/revwalk.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/settings.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/sha1_lookup.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/signature.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/streams/socket.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/sortedcache.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/stash.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/status.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/strmap.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/submodule.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/sysdir.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/tag.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/thread-utils.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/trace.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/trailer.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transaction.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transport.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/cred_helpers.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/cred.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/git.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/local.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/smart_pkt.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/smart_protocol.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/smart.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/ssh.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/tree-cache.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/tree.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/tsort.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/util.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/varint.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/vector.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/wildmatch.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/worktree.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/xdiff/xdiffi.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/xdiff/xemit.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/xdiff/xhistogram.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/xdiff/xmerge.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/xdiff/xpatience.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/xdiff/xprepare.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/xdiff/xutils.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/zstream.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/streams/stransport.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/http.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/auth.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/auth_negotiate.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/auth_ntlm.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/streams/tls.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/unix/map.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/unix/realpath.o\nnpm ERR! LIBTOOL-STATIC Release/git2.a\nnpm ERR! CC(target) Release/obj.target/zlib/vendor/libgit2/deps/zlib/adler32.o\nnpm ERR! CC(target) Release/obj.target/zlib/vendor/libgit2/deps/zlib/crc32.o\nnpm ERR! CC(target) Release/obj.target/zlib/vendor/libgit2/deps/zlib/deflate.o\nnpm ERR! CC(target) Release/obj.target/zlib/vendor/libgit2/deps/zlib/inffast.o\nnpm ERR! CC(target) Release/obj.target/zlib/vendor/libgit2/deps/zlib/inflate.o\nnpm ERR! CC(target) Release/obj.target/zlib/vendor/libgit2/deps/zlib/inftrees.o\nnpm ERR! CC(target) Release/obj.target/zlib/vendor/libgit2/deps/zlib/trees.o\nnpm ERR! CC(target) Release/obj.target/zlib/vendor/libgit2/deps/zlib/zutil.o\nnpm ERR! LIBTOOL-STATIC Release/zlib.a\nnpm ERR! CC(target) Release/obj.target/http_parser/vendor/http_parser/http_parser.o\nnpm ERR! LIBTOOL-STATIC Release/http_parser.a\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/agent.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/bcrypt_pbkdf.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/blowfish.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/crypt.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/keepalive.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/libgcrypt.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/openssl.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/publickey.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/sftp.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/version.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/channel.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/global.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/kex.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/mac.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/packet.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/scp.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/transport.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/comp.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/hostkey.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/knownhost.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/misc.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/pem.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/session.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/userauth.o\nnpm ERR! LIBTOOL-STATIC Release/ssh2.a\nnpm ERR! CC(target) Release/obj.target/ntlmclient/vendor/libgit2/deps/ntlmclient/ntlm.o\nnpm ERR! CC(target) Release/obj.target/ntlmclient/vendor/libgit2/deps/ntlmclient/unicode_builtin.o\nnpm ERR! CC(target) Release/obj.target/ntlmclient/vendor/libgit2/deps/ntlmclient/util.o\nnpm ERR! CC(target) Release/obj.target/ntlmclient/vendor/libgit2/deps/ntlmclient/crypt_commoncrypto.o\nnpm ERR! LIBTOOL-STATIC Release/ntlmclient.a\nnpm ERR! CXX(target) Release/obj.target/nodegit/src/async_baton.o\nnpm ERR! Failed to execute '/usr/local/Cellar/node/16.8.0/bin/node /usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js build --fallback-to-build --module=/usr/local/lib/node_modules/nodegit/build/Release/nodegit.node --module_name=nodegit --module_path=/usr/local/lib/node_modules/nodegit/build/Release --napi_version=8 --node_abi_napi=napi --napi_build_version=0 --node_napi_label=node-v93' (1)\nnpm ERR! node-pre-gyp\nnpm ERR! info it worked if it ends with ok\nnpm ERR! node-pre-gyp info\nnpm ERR! using node-pre-gyp@0.13.0\nnpm ERR! node-pre-gyp info using node@16.8.0 | darwin | x64\nnpm ERR! node-pre-gyp WARN Using request for node-pre-gyp https download\nnpm ERR! node-pre-gyp info check checked for \"/usr/local/lib/node_modules/nodegit/build/Release/nodegit.node\" (not found)\nnpm ERR! node-pre-gyp http GET\nnpm ERR! https://axonodegit.s3.amazonaws.com/nodegit/nodegit/nodegit-v0.27.0-node-v93-darwin-x64.tar.gz\nnpm ERR! node-pre-gyp WARN\nnpm ERR! Pre-built binaries not installable for nodegit@0.27.0 and node@16.8.0 (node-v93 ABI, unknown) (falling back to source compile with node-gyp) \nnpm ERR! node-pre-gyp WARN Hit error unable to get local issuer certificate\nnpm ERR! gyp\nnpm ERR! info\nnpm ERR! it worked if it ends with ok\nnpm ERR! gyp info using\nnpm ERR! node-gyp@7.1.2\nnpm ERR! gyp info using node@16.8.0 | darwin | x64\nnpm ERR! gyp info ok\nnpm ERR! \nnpm ERR! gyp info it worked if it ends with ok\nnpm ERR! gyp info using node-gyp@7.1.2\nnpm ERR! gyp info using node@16.8.0 | darwin | x64\nnpm ERR! gyp info find Python using Python version 3.9.6 found at \"/Users/johe/.venv/default/bin/python3\"\nnpm ERR! (node:46067) [DEP0150] DeprecationWarning: Setting process.config is deprecated. In the future the property will be read-only.\nnpm ERR! (Use `node --trace-deprecation ...` to show where the warning was created)\nnpm ERR! gyp info\nnpm ERR! spawn /Users/johe/.venv/default/bin/python3\nnpm ERR! gyp info spawn args [\nnpm ERR! gyp info spawn args\nnpm ERR! '/usr/local/lib/node_modules/npm/node_modules/node-gyp/gyp/gyp_main.py',\nnpm ERR! gyp info spawn args   'binding.gyp',\nnpm ERR! gyp info spawn args   '-f',\nnpm ERR! gyp info spawn args   'make',\nnpm ERR! gyp info\nnpm ERR! spawn args   '-I',\nnpm ERR! gyp info spawn args   '/usr/local/lib/node_modules/nodegit/build/config.gypi',\nnpm ERR! gyp info spawn args   '-I',\nnpm ERR! gyp\nnpm ERR! info spawn args   '/usr/local/lib/node_modules/npm/node_modules/node-gyp/addon.gypi',\nnpm ERR! gyp info spawn args   '-I',\nnpm ERR! gyp info\nnpm ERR! spawn args   '/Users/johe/Library/Caches/node-gyp/16.8.0/include/node/common.gypi',\nnpm ERR! gyp info spawn args   '-Dlibrary=shared_library',\nnpm ERR! gyp info spawn args\nnpm ERR! '-Dvisibility=default',\nnpm ERR! gyp info spawn args\nnpm ERR! '-Dnode_root_dir=/Users/johe/Library/Caches/node-gyp/16.8.0',\nnpm ERR! gyp\nnpm ERR! info spawn args   '-Dnode_gyp_dir=/usr/local/lib/node_modules/npm/node_modules/node-gyp',\nnpm ERR! gyp info spawn args   '-Dnode_lib_file=/Users/johe/Library/Caches/node-gyp/16.8.0/<(target_arch)/node.lib',\nnpm ERR! gyp info spawn args   '-Dmodule_root_dir=/usr/local/lib/node_modules/nodegit',\nnpm ERR! gyp info\nnpm ERR! spawn args   '-Dnode_engine=v8',\nnpm ERR! gyp info spawn args   '--depth=.',\nnpm ERR! gyp info spawn args\nnpm ERR! '--no-parallel',\nnpm ERR! gyp info spawn args   '--generator-output',\nnpm ERR! gyp info spawn args\nnpm ERR! 'build',\nnpm ERR! gyp info spawn args   '-Goutput_dir=.'\nnpm ERR! gyp info\nnpm ERR! spawn args ]\nnpm ERR! gyp info ok\nnpm ERR! gyp\nnpm ERR! info it worked if it ends with ok\nnpm ERR! gyp\nnpm ERR! info using node-gyp@7.1.2\nnpm ERR! gyp info using\nnpm ERR! node@16.8.0 | darwin | x64\nnpm ERR! gyp info spawn make\nnpm ERR! gyp info spawn args [ 'BUILDTYPE=Release', '-C', 'build' ]\nnpm ERR! ../vendor/libssh2/src/bcrypt_pbkdf.c:84:46: warning: expression does not compute the number of elements in this array; element type is 'uint32_t' (aka 'unsigned int'), not 'uint64_t' (aka 'unsigned long long') [-Wsizeof-array-div]\nnpm ERR! blf_enc(&state, cdata, sizeof(cdata) / sizeof(uint64_t));\nnpm ERR!                                       ~~~~~  ^\nnpm ERR! ../vendor/libssh2/src/bcrypt_pbkdf.c:65:14: note: array 'cdata' declared here\nnpm ERR!     uint32_t cdata[BCRYPT_BLOCKS];\nnpm ERR!              ^\nnpm ERR! ../vendor/libssh2/src/bcrypt_pbkdf.c:84:46: note: place parentheses around the 'sizeof(uint64_t)' expression to silence this warning\nnpm ERR!         blf_enc(&state, cdata, sizeof(cdata) / sizeof(uint64_t));\nnpm ERR!                                              ^\nnpm ERR! 1 warning generated.\nnpm ERR! In file included from ../src/async_baton.cc:1:\nnpm ERR! In file included from ../src/../include/async_baton.h:5:\nnpm ERR! In file included from ../node_modules/nan/nan.h:58:\nnpm ERR! In file included from /Users/johe/Library/Caches/node-gyp/16.8.0/include/node/node.h:63:\nnpm ERR! In file included from /Users/johe/Library/Caches/node-gyp/16.8.0/include/node/v8.h:30:\nnpm ERR! /Users/johe/Library/Caches/node-gyp/16.8.0/include/node/v8-internal.h:488:38: error: no template named 'remove_cv_t' in namespace 'std'; did you mean 'remove_cv'?\nnpm ERR! !std::is_same<Data, std::remove_cv_t<T>>::value>::Perform(data);\nnpm ERR!                                 ~~~~~^~~~~~~~~~~\nnpm ERR!                                      remove_cv\nnpm ERR! /Library/Developer/CommandLineTools/SDKs/MacOSX.sdk/usr/include/c++/v1/type_traits:776:50: note: 'remove_cv' declared here\nnpm ERR! template <class _Tp> struct _LIBCPP_TEMPLATE_VIS remove_cv\nnpm ERR! ^\nnpm ERR! 1 error generated.\nnpm ERR! make: *** [Release/obj.target/nodegit/src/async_baton.o] Error 1\nnpm ERR! gyp\nnpm ERR! ERR! build error\nnpm ERR! gyp\nnpm ERR! ERR! stack Error: `make` failed with exit code: 2\nnpm ERR! gyp ERR! stack     at ChildProcess.onExit (/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:194:23)\nnpm ERR! gyp ERR! stack     at ChildProcess.emit (node:events:394:28)\nnpm ERR! gyp\nnpm ERR! ERR! stack     at Process.ChildProcess._handle.onexit (node:internal/child_process:290:12)\nnpm ERR! gyp ERR! System Darwin 20.5.0\nnpm ERR! gyp ERR! command \"/usr/local/Cellar/node/16.8.0/bin/node\" \"/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js\" \"build\" \"--fallback-to-build\" \"--module=/usr/local/lib/node_modules/nodegit/build/Release/nodegit.node\" \"--module_name=nodegit\" \"--module_path=/usr/local/lib/node_modules/nodegit/build/Release\" \"--napi_version=8\" \"--node_abi_napi=napi\" \"--napi_build_version=0\" \"--node_napi_label=node-v93\"\nnpm ERR! gyp ERR! cwd /usr/local/lib/node_modules/nodegit\nnpm ERR! gyp ERR! node -v\nnpm ERR! v16.8.0\nnpm ERR! gyp ERR! node-gyp -v v7.1.2\nnpm ERR! gyp\nnpm ERR! ERR! not ok\nnpm ERR! node-pre-gyp ERR!\nnpm ERR! build error\nnpm ERR! node-pre-gyp ERR! stack Error: Failed to execute '/usr/local/Cellar/node/16.8.0/bin/node /usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js build --fallback-to-build --module=/usr/local/lib/node_modules/nodegit/build/Release/nodegit.node --module_name=nodegit --module_path=/usr/local/lib/node_modules/nodegit/build/Release --napi_version=8 --node_abi_napi=napi --napi_build_version=0 --node_napi_label=node-v93' (1)\nnpm ERR! node-pre-gyp ERR! stack     at ChildProcess.<anonymous> (/usr/local/lib/node_modules/nodegit/node_modules/node-pre-gyp/lib/util/compile.js:83:29)\nnpm ERR! node-pre-gyp ERR! stack     at ChildProcess.emit (node:events:394:28)\nnpm ERR! node-pre-gyp ERR! stack     at maybeClose (node:internal/child_process:1064:16)\nnpm ERR! node-pre-gyp ERR! stack     at Process.ChildProcess._handle.onexit (node:internal/child_process:301:5)\nnpm ERR! node-pre-gyp\nnpm ERR! ERR! System Darwin 20.5.0\nnpm ERR! node-pre-gyp ERR! command\nnpm ERR! \"/usr/local/Cellar/node/16.8.0/bin/node\" \"/usr/local/lib/node_modules/nodegit/node_modules/.bin/node-pre-gyp\" \"install\" \"--fallback-to-build\"\nnpm ERR! node-pre-gyp ERR! cwd /usr/local/lib/node_modules/nodegit\nnpm ERR! node-pre-gyp\nnpm ERR! ERR! node -v v16.8.0\nnpm ERR! node-pre-gyp ERR!\nnpm ERR! node-pre-gyp -v v0.13.0\nnpm ERR! node-pre-gyp ERR! not ok\nnpm ERR! [nodegit] ERROR - Could not finish install\nnpm ERR! [nodegit] ERROR - finished with error code: 1\n\nnpm ERR! A complete log of this run can be found in:\nnpm ERR!     /Users/johe/.npm/_logs/2021-09-02T11_02_24_084Z-debug.log", "stderr_lines": ["npm WARN deprecated har-validator@5.1.5: this library is no longer supported", "npm WARN deprecated uuid@3.4.0: Please upgrade  to version 7 or higher.  Older versions may use Math.random() in certain circumstances, which is known to be problematic.  See https://v8.dev/blog/math-random for details.", "npm WARN deprecated request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142", "npm WARN deprecated node-pre-gyp@0.13.0: Please upgrade to @mapbox/node-pre-gyp: the non-scoped node-pre-gyp package is deprecated and only the @mapbox scoped package will recieve updates in the future", "npm ERR! code 1", "npm ERR! path /usr/local/lib/node_modules/nodegit", "npm ERR! command failed", "npm ERR! command sh -c node lifecycleScripts/preinstall && node lifecycleScripts/install", "npm ERR! [nodegit] Running pre-install script", "npm ERR! [nodegit] Running install script", "npm ERR! SOLINK_MODULE(target) Release/acquireOpenSSL.node", "npm ERR! ACTION binding_gyp_configureLibssh2_target_configure .", "npm ERR! [nodegit] Configuring libssh2.", "npm ERR! SOLINK_MODULE(target) Release/configureLibssh2.node", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/allocators/stdalloc.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/commit.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/alloc.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/annotated_commit.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/apply.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/attr_file.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/attr.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/attrcache.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/blame_git.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/blame.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/blob.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/branch.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/buf_text.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/buffer.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/cache.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/checkout.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/cherrypick.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/clone.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/commit_list.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/config_cache.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/config_entries.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/config_file.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/config_mem.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/config_parse.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/config_snapshot.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/config.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/crlf.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/date.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/delta.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/diff_driver.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/diff_file.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/diff_generate.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/diff_parse.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/diff_print.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/diff_stats.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/diff_tform.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/diff_xdiff.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/diff.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/errors.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/fetch.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/fetchhead.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/filebuf.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/futils.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/filter.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/global.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/graph.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/hash.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/hash/sha1/sha1dc/sha1.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/hash/sha1/sha1dc/ubc_check.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/hash/sha1/collisiondetect.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/hashsig.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/ident.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/idxmap.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/ignore.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/index.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/indexer.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/iterator.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/mailmap.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/merge_driver.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/merge_file.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/merge.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/message.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/mwindow.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/net.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/netops.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/notes.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/object_api.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/object.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/odb_loose.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/odb_mempack.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/odb_pack.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/odb.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/offmap.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/oid.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/oidarray.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/oidmap.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/streams/mbedtls.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/streams/openssl.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/streams/registry.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/pack-objects.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/pack.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/parse.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/patch_generate.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/patch_parse.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/patch.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/path.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/pathspec.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/pool.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/posix.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/pqueue.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/proxy.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/push.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/reader.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/rebase.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/refdb_fs.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/refdb.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/reflog.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/refs.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/refspec.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/regexp.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/remote.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/repository.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/reset.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/revert.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/revparse.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/revwalk.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/settings.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/sha1_lookup.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/signature.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/streams/socket.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/sortedcache.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/stash.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/status.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/strmap.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/submodule.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/sysdir.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/tag.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/thread-utils.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/trace.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/trailer.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transaction.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transport.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/cred_helpers.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/cred.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/git.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/local.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/smart_pkt.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/smart_protocol.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/smart.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/ssh.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/tree-cache.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/tree.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/tsort.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/util.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/varint.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/vector.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/wildmatch.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/worktree.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/xdiff/xdiffi.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/xdiff/xemit.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/xdiff/xhistogram.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/xdiff/xmerge.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/xdiff/xpatience.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/xdiff/xprepare.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/xdiff/xutils.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/zstream.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/streams/stransport.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/http.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/auth.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/auth_negotiate.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/auth_ntlm.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/streams/tls.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/unix/map.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/unix/realpath.o", "npm ERR! LIBTOOL-STATIC Release/git2.a", "npm ERR! CC(target) Release/obj.target/zlib/vendor/libgit2/deps/zlib/adler32.o", "npm ERR! CC(target) Release/obj.target/zlib/vendor/libgit2/deps/zlib/crc32.o", "npm ERR! CC(target) Release/obj.target/zlib/vendor/libgit2/deps/zlib/deflate.o", "npm ERR! CC(target) Release/obj.target/zlib/vendor/libgit2/deps/zlib/inffast.o", "npm ERR! CC(target) Release/obj.target/zlib/vendor/libgit2/deps/zlib/inflate.o", "npm ERR! CC(target) Release/obj.target/zlib/vendor/libgit2/deps/zlib/inftrees.o", "npm ERR! CC(target) Release/obj.target/zlib/vendor/libgit2/deps/zlib/trees.o", "npm ERR! CC(target) Release/obj.target/zlib/vendor/libgit2/deps/zlib/zutil.o", "npm ERR! LIBTOOL-STATIC Release/zlib.a", "npm ERR! CC(target) Release/obj.target/http_parser/vendor/http_parser/http_parser.o", "npm ERR! LIBTOOL-STATIC Release/http_parser.a", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/agent.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/bcrypt_pbkdf.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/blowfish.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/crypt.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/keepalive.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/libgcrypt.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/openssl.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/publickey.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/sftp.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/version.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/channel.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/global.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/kex.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/mac.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/packet.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/scp.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/transport.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/comp.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/hostkey.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/knownhost.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/misc.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/pem.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/session.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/userauth.o", "npm ERR! LIBTOOL-STATIC Release/ssh2.a", "npm ERR! CC(target) Release/obj.target/ntlmclient/vendor/libgit2/deps/ntlmclient/ntlm.o", "npm ERR! CC(target) Release/obj.target/ntlmclient/vendor/libgit2/deps/ntlmclient/unicode_builtin.o", "npm ERR! CC(target) Release/obj.target/ntlmclient/vendor/libgit2/deps/ntlmclient/util.o", "npm ERR! CC(target) Release/obj.target/ntlmclient/vendor/libgit2/deps/ntlmclient/crypt_commoncrypto.o", "npm ERR! LIBTOOL-STATIC Release/ntlmclient.a", "npm ERR! CXX(target) Release/obj.target/nodegit/src/async_baton.o", "npm ERR! Failed to execute '/usr/local/Cellar/node/16.8.0/bin/node /usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js build --fallback-to-build --module=/usr/local/lib/node_modules/nodegit/build/Release/nodegit.node --module_name=nodegit --module_path=/usr/local/lib/node_modules/nodegit/build/Release --napi_version=8 --node_abi_napi=napi --napi_build_version=0 --node_napi_label=node-v93' (1)", "npm ERR! node-pre-gyp", "npm ERR! info it worked if it ends with ok", "npm ERR! node-pre-gyp info", "npm ERR! using node-pre-gyp@0.13.0", "npm ERR! node-pre-gyp info using node@16.8.0 | darwin | x64", "npm ERR! node-pre-gyp WARN Using request for node-pre-gyp https download", "npm ERR! node-pre-gyp info check checked for \"/usr/local/lib/node_modules/nodegit/build/Release/nodegit.node\" (not found)", "npm ERR! node-pre-gyp http GET", "npm ERR! https://axonodegit.s3.amazonaws.com/nodegit/nodegit/nodegit-v0.27.0-node-v93-darwin-x64.tar.gz", "npm ERR! node-pre-gyp WARN", "npm ERR! Pre-built binaries not installable for nodegit@0.27.0 and node@16.8.0 (node-v93 ABI, unknown) (falling back to source compile with node-gyp) ", "npm ERR! node-pre-gyp WARN Hit error unable to get local issuer certificate", "npm ERR! gyp", "npm ERR! info", "npm ERR! it worked if it ends with ok", "npm ERR! gyp info using", "npm ERR! node-gyp@7.1.2", "npm ERR! gyp info using node@16.8.0 | darwin | x64", "npm ERR! gyp info ok", "npm ERR! ", "npm ERR! gyp info it worked if it ends with ok", "npm ERR! gyp info using node-gyp@7.1.2", "npm ERR! gyp info using node@16.8.0 | darwin | x64", "npm ERR! gyp info find Python using Python version 3.9.6 found at \"/Users/johe/.venv/default/bin/python3\"", "npm ERR! (node:46067) [DEP0150] DeprecationWarning: Setting process.config is deprecated. In the future the property will be read-only.", "npm ERR! (Use `node --trace-deprecation ...` to show where the warning was created)", "npm ERR! gyp info", "npm ERR! spawn /Users/johe/.venv/default/bin/python3", "npm ERR! gyp info spawn args [", "npm ERR! gyp info spawn args", "npm ERR! '/usr/local/lib/node_modules/npm/node_modules/node-gyp/gyp/gyp_main.py',", "npm ERR! gyp info spawn args   'binding.gyp',", "npm ERR! gyp info spawn args   '-f',", "npm ERR! gyp info spawn args   'make',", "npm ERR! gyp info", "npm ERR! spawn args   '-I',", "npm ERR! gyp info spawn args   '/usr/local/lib/node_modules/nodegit/build/config.gypi',", "npm ERR! gyp info spawn args   '-I',", "npm ERR! gyp", "npm ERR! info spawn args   '/usr/local/lib/node_modules/npm/node_modules/node-gyp/addon.gypi',", "npm ERR! gyp info spawn args   '-I',", "npm ERR! gyp info", "npm ERR! spawn args   '/Users/johe/Library/Caches/node-gyp/16.8.0/include/node/common.gypi',", "npm ERR! gyp info spawn args   '-Dlibrary=shared_library',", "npm ERR! gyp info spawn args", "npm ERR! '-Dvisibility=default',", "npm ERR! gyp info spawn args", "npm ERR! '-Dnode_root_dir=/Users/johe/Library/Caches/node-gyp/16.8.0',", "npm ERR! gyp", "npm ERR! info spawn args   '-Dnode_gyp_dir=/usr/local/lib/node_modules/npm/node_modules/node-gyp',", "npm ERR! gyp info spawn args   '-Dnode_lib_file=/Users/johe/Library/Caches/node-gyp/16.8.0/<(target_arch)/node.lib',", "npm ERR! gyp info spawn args   '-Dmodule_root_dir=/usr/local/lib/node_modules/nodegit',", "npm ERR! gyp info", "npm ERR! spawn args   '-Dnode_engine=v8',", "npm ERR! gyp info spawn args   '--depth=.',", "npm ERR! gyp info spawn args", "npm ERR! '--no-parallel',", "npm ERR! gyp info spawn args   '--generator-output',", "npm ERR! gyp info spawn args", "npm ERR! 'build',", "npm ERR! gyp info spawn args   '-Goutput_dir=.'", "npm ERR! gyp info", "npm ERR! spawn args ]", "npm ERR! gyp info ok", "npm ERR! gyp", "npm ERR! info it worked if it ends with ok", "npm ERR! gyp", "npm ERR! info using node-gyp@7.1.2", "npm ERR! gyp info using", "npm ERR! node@16.8.0 | darwin | x64", "npm ERR! gyp info spawn make", "npm ERR! gyp info spawn args [ 'BUILDTYPE=Release', '-C', 'build' ]", "npm ERR! ../vendor/libssh2/src/bcrypt_pbkdf.c:84:46: warning: expression does not compute the number of elements in this array; element type is 'uint32_t' (aka 'unsigned int'), not 'uint64_t' (aka 'unsigned long long') [-Wsizeof-array-div]", "npm ERR! blf_enc(&state, cdata, sizeof(cdata) / sizeof(uint64_t));", "npm ERR!                                       ~~~~~  ^", "npm ERR! ../vendor/libssh2/src/bcrypt_pbkdf.c:65:14: note: array 'cdata' declared here", "npm ERR!     uint32_t cdata[BCRYPT_BLOCKS];", "npm ERR!              ^", "npm ERR! ../vendor/libssh2/src/bcrypt_pbkdf.c:84:46: note: place parentheses around the 'sizeof(uint64_t)' expression to silence this warning", "npm ERR!         blf_enc(&state, cdata, sizeof(cdata) / sizeof(uint64_t));", "npm ERR!                                              ^", "npm ERR! 1 warning generated.", "npm ERR! In file included from ../src/async_baton.cc:1:", "npm ERR! In file included from ../src/../include/async_baton.h:5:", "npm ERR! In file included from ../node_modules/nan/nan.h:58:", "npm ERR! In file included from /Users/johe/Library/Caches/node-gyp/16.8.0/include/node/node.h:63:", "npm ERR! In file included from /Users/johe/Library/Caches/node-gyp/16.8.0/include/node/v8.h:30:", "npm ERR! /Users/johe/Library/Caches/node-gyp/16.8.0/include/node/v8-internal.h:488:38: error: no template named 'remove_cv_t' in namespace 'std'; did you mean 'remove_cv'?", "npm ERR! !std::is_same<Data, std::remove_cv_t<T>>::value>::Perform(data);", "npm ERR!                                 ~~~~~^~~~~~~~~~~", "npm ERR!                                      remove_cv", "npm ERR! /Library/Developer/CommandLineTools/SDKs/MacOSX.sdk/usr/include/c++/v1/type_traits:776:50: note: 'remove_cv' declared here", "npm ERR! template <class _Tp> struct _LIBCPP_TEMPLATE_VIS remove_cv", "npm ERR! ^", "npm ERR! 1 error generated.", "npm ERR! make: *** [Release/obj.target/nodegit/src/async_baton.o] Error 1", "npm ERR! gyp", "npm ERR! ERR! build error", "npm ERR! gyp", "npm ERR! ERR! stack Error: `make` failed with exit code: 2", "npm ERR! gyp ERR! stack     at ChildProcess.onExit (/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:194:23)", "npm ERR! gyp ERR! stack     at ChildProcess.emit (node:events:394:28)", "npm ERR! gyp", "npm ERR! ERR! stack     at Process.ChildProcess._handle.onexit (node:internal/child_process:290:12)", "npm ERR! gyp ERR! System Darwin 20.5.0", "npm ERR! gyp ERR! command \"/usr/local/Cellar/node/16.8.0/bin/node\" \"/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js\" \"build\" \"--fallback-to-build\" \"--module=/usr/local/lib/node_modules/nodegit/build/Release/nodegit.node\" \"--module_name=nodegit\" \"--module_path=/usr/local/lib/node_modules/nodegit/build/Release\" \"--napi_version=8\" \"--node_abi_napi=napi\" \"--napi_build_version=0\" \"--node_napi_label=node-v93\"", "npm ERR! gyp ERR! cwd /usr/local/lib/node_modules/nodegit", "npm ERR! gyp ERR! node -v", "npm ERR! v16.8.0", "npm ERR! gyp ERR! node-gyp -v v7.1.2", "npm ERR! gyp", "npm ERR! ERR! not ok", "npm ERR! node-pre-gyp ERR!", "npm ERR! build error", "npm ERR! node-pre-gyp ERR! stack Error: Failed to execute '/usr/local/Cellar/node/16.8.0/bin/node /usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js build --fallback-to-build --module=/usr/local/lib/node_modules/nodegit/build/Release/nodegit.node --module_name=nodegit --module_path=/usr/local/lib/node_modules/nodegit/build/Release --napi_version=8 --node_abi_napi=napi --napi_build_version=0 --node_napi_label=node-v93' (1)", "npm ERR! node-pre-gyp ERR! stack     at ChildProcess.<anonymous> (/usr/local/lib/node_modules/nodegit/node_modules/node-pre-gyp/lib/util/compile.js:83:29)", "npm ERR! node-pre-gyp ERR! stack     at ChildProcess.emit (node:events:394:28)", "npm ERR! node-pre-gyp ERR! stack     at maybeClose (node:internal/child_process:1064:16)", "npm ERR! node-pre-gyp ERR! stack     at Process.ChildProcess._handle.onexit (node:internal/child_process:301:5)", "npm ERR! node-pre-gyp", "npm ERR! ERR! System Darwin 20.5.0", "npm ERR! node-pre-gyp ERR! command", "npm ERR! \"/usr/local/Cellar/node/16.8.0/bin/node\" \"/usr/local/lib/node_modules/nodegit/node_modules/.bin/node-pre-gyp\" \"install\" \"--fallback-to-build\"", "npm ERR! node-pre-gyp ERR! cwd /usr/local/lib/node_modules/nodegit", "npm ERR! node-pre-gyp", "npm ERR! ERR! node -v v16.8.0", "npm ERR! node-pre-gyp ERR!", "npm ERR! node-pre-gyp -v v0.13.0", "npm ERR! node-pre-gyp ERR! not ok", "npm ERR! [nodegit] ERROR - Could not finish install", "npm ERR! [nodegit] ERROR - finished with error code: 1", "", "npm ERR! A complete log of this run can be found in:", "npm ERR!     /Users/johe/.npm/_logs/2021-09-02T11_02_24_084Z-debug.log"], "stdout": "", "stdout_lines": []}
changed: [localhost] => (item=dockerfile_lint)
failed: [localhost] (item=generator-basalt) => {"ansible_loop_var": "item", "changed": true, "cmd": ["npm", "install", "-g", "generator-basalt"], "delta": "0:02:31.921036", "end": "2021-09-02 13:05:00.369098", "item": "generator-basalt", "msg": "non-zero return code", "rc": 1, "start": "2021-09-02 13:02:28.448062", "stderr": "npm WARN deprecated urix@0.1.0: Please see https://github.com/lydell/urix#deprecated\nnpm WARN deprecated har-validator@5.1.5: this library is no longer supported\nnpm WARN deprecated resolve-url@0.2.1: https://github.com/lydell/resolve-url#deprecated\nnpm WARN deprecated uuid@3.4.0: Please upgrade  to version 7 or higher.  Older versions may use Math.random() in certain circumstances, which is known to be problematic.  See https://v8.dev/blog/math-random for details.\nnpm WARN deprecated request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142\nnpm WARN deprecated node-pre-gyp@0.13.0: Please upgrade to @mapbox/node-pre-gyp: the non-scoped node-pre-gyp package is deprecated and only the @mapbox scoped package will recieve updates in the future\nnpm ERR! code 1\nnpm ERR! path /usr/local/lib/node_modules/generator-basalt/node_modules/nodegit\nnpm ERR! command failed\nnpm ERR! command sh -c node lifecycleScripts/preinstall && node lifecycleScripts/install\nnpm ERR! [nodegit] Running pre-install script\nnpm ERR! [nodegit] Running install script\nnpm ERR! SOLINK_MODULE(target) Release/acquireOpenSSL.node\nnpm ERR! ACTION binding_gyp_configureLibssh2_target_configure .\nnpm ERR! [nodegit] Configuring libssh2.\nnpm ERR! SOLINK_MODULE(target) Release/configureLibssh2.node\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/allocators/stdalloc.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/commit.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/alloc.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/annotated_commit.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/apply.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/attr_file.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/attr.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/attrcache.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/blame_git.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/blame.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/blob.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/branch.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/buf_text.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/buffer.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/cache.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/checkout.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/cherrypick.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/clone.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/commit_list.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/config_cache.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/config_entries.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/config_file.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/config_mem.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/config_parse.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/config_snapshot.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/config.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/crlf.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/date.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/delta.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/diff_driver.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/diff_file.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/diff_generate.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/diff_parse.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/diff_print.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/diff_stats.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/diff_tform.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/diff_xdiff.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/diff.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/errors.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/fetch.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/fetchhead.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/filebuf.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/futils.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/filter.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/global.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/graph.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/hash.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/hash/sha1/sha1dc/sha1.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/hash/sha1/sha1dc/ubc_check.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/hash/sha1/collisiondetect.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/hashsig.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/ident.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/idxmap.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/ignore.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/index.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/indexer.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/iterator.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/mailmap.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/merge_driver.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/merge_file.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/merge.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/message.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/mwindow.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/net.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/netops.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/notes.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/object_api.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/object.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/odb_loose.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/odb_mempack.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/odb_pack.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/odb.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/offmap.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/oid.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/oidarray.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/oidmap.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/streams/mbedtls.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/streams/openssl.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/streams/registry.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/pack-objects.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/pack.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/parse.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/patch_generate.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/patch_parse.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/patch.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/path.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/pathspec.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/pool.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/posix.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/pqueue.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/proxy.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/push.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/reader.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/rebase.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/refdb_fs.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/refdb.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/reflog.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/refs.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/refspec.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/regexp.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/remote.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/repository.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/reset.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/revert.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/revparse.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/revwalk.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/settings.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/sha1_lookup.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/signature.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/streams/socket.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/sortedcache.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/stash.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/status.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/strmap.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/submodule.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/sysdir.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/tag.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/thread-utils.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/trace.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/trailer.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transaction.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transport.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/cred_helpers.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/cred.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/git.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/local.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/smart_pkt.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/smart_protocol.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/smart.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/ssh.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/tree-cache.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/tree.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/tsort.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/util.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/varint.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/vector.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/wildmatch.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/worktree.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/xdiff/xdiffi.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/xdiff/xemit.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/xdiff/xhistogram.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/xdiff/xmerge.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/xdiff/xpatience.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/xdiff/xprepare.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/xdiff/xutils.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/zstream.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/streams/stransport.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/http.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/auth.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/auth_negotiate.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/auth_ntlm.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/streams/tls.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/unix/map.o\nnpm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/unix/realpath.o\nnpm ERR! LIBTOOL-STATIC Release/git2.a\nnpm ERR! CC(target) Release/obj.target/zlib/vendor/libgit2/deps/zlib/adler32.o\nnpm ERR! CC(target) Release/obj.target/zlib/vendor/libgit2/deps/zlib/crc32.o\nnpm ERR! CC(target) Release/obj.target/zlib/vendor/libgit2/deps/zlib/deflate.o\nnpm ERR! CC(target) Release/obj.target/zlib/vendor/libgit2/deps/zlib/inffast.o\nnpm ERR! CC(target) Release/obj.target/zlib/vendor/libgit2/deps/zlib/inflate.o\nnpm ERR! CC(target) Release/obj.target/zlib/vendor/libgit2/deps/zlib/inftrees.o\nnpm ERR! CC(target) Release/obj.target/zlib/vendor/libgit2/deps/zlib/trees.o\nnpm ERR! CC(target) Release/obj.target/zlib/vendor/libgit2/deps/zlib/zutil.o\nnpm ERR! LIBTOOL-STATIC Release/zlib.a\nnpm ERR! CC(target) Release/obj.target/http_parser/vendor/http_parser/http_parser.o\nnpm ERR! LIBTOOL-STATIC Release/http_parser.a\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/agent.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/bcrypt_pbkdf.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/blowfish.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/crypt.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/keepalive.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/libgcrypt.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/openssl.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/publickey.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/sftp.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/version.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/channel.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/global.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/kex.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/mac.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/packet.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/scp.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/transport.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/comp.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/hostkey.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/knownhost.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/misc.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/pem.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/session.o\nnpm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/userauth.o\nnpm ERR! LIBTOOL-STATIC Release/ssh2.a\nnpm ERR! CC(target) Release/obj.target/ntlmclient/vendor/libgit2/deps/ntlmclient/ntlm.o\nnpm ERR! CC(target) Release/obj.target/ntlmclient/vendor/libgit2/deps/ntlmclient/unicode_builtin.o\nnpm ERR! CC(target) Release/obj.target/ntlmclient/vendor/libgit2/deps/ntlmclient/util.o\nnpm ERR! CC(target) Release/obj.target/ntlmclient/vendor/libgit2/deps/ntlmclient/crypt_commoncrypto.o\nnpm ERR! LIBTOOL-STATIC Release/ntlmclient.a\nnpm ERR! CXX(target) Release/obj.target/nodegit/src/async_baton.o\nnpm ERR! Failed to execute '/usr/local/Cellar/node/16.8.0/bin/node /usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js build --fallback-to-build --module=/usr/local/lib/node_modules/generator-basalt/node_modules/nodegit/build/Release/nodegit.node --module_name=nodegit --module_path=/usr/local/lib/node_modules/generator-basalt/node_modules/nodegit/build/Release --napi_version=8 --node_abi_napi=napi --napi_build_version=0 --node_napi_label=node-v93' (1)\nnpm ERR! node-pre-gyp\nnpm ERR! info it worked if it ends with ok\nnpm ERR! node-pre-gyp info using node-pre-gyp@0.13.0\nnpm ERR! node-pre-gyp info using node@16.8.0 | darwin | x64\nnpm ERR! node-pre-gyp WARN\nnpm ERR! Using request for node-pre-gyp https download\nnpm ERR! node-pre-gyp info\nnpm ERR! check checked for \"/usr/local/lib/node_modules/generator-basalt/node_modules/nodegit/build/Release/nodegit.node\" (not found)\nnpm ERR! node-pre-gyp\nnpm ERR! http GET https://axonodegit.s3.amazonaws.com/nodegit/nodegit/nodegit-v0.27.0-node-v93-darwin-x64.tar.gz\nnpm ERR! node-pre-gyp\nnpm ERR! WARN Pre-built binaries not installable for nodegit@0.27.0 and node@16.8.0 (node-v93 ABI, unknown) (falling back to source compile with node-gyp) \nnpm ERR! node-pre-gyp WARN Hit error unable to get local issuer certificate\nnpm ERR! gyp\nnpm ERR! \nnpm ERR! info it worked if it ends with\nnpm ERR! ok\nnpm ERR! gyp\nnpm ERR! info using node-gyp@7.1.2\nnpm ERR! gyp\nnpm ERR! \nnpm ERR! info\nnpm ERR! \nnpm ERR! using\nnpm ERR! node@16.8.0 | darwin | x64\nnpm ERR! gyp\nnpm ERR! info ok\nnpm ERR! gyp\nnpm ERR! info it worked if it ends with ok\nnpm ERR! gyp\nnpm ERR! info using node-gyp@7.1.2\nnpm ERR! gyp info using node@16.8.0 | darwin | x64\nnpm ERR! gyp info find Python\nnpm ERR! using Python version 3.9.6 found at \"/Users/johe/.venv/default/bin/python3\"\nnpm ERR! (node:57031) [DEP0150] DeprecationWarning: Setting process.config is deprecated. In the future the property will be read-only.\nnpm ERR! (Use `node --trace-deprecation ...` to show where the warning was created)\nnpm ERR! gyp\nnpm ERR! \nnpm ERR! info\nnpm ERR! \nnpm ERR! spawn\nnpm ERR! /Users/johe/.venv/default/bin/python3\nnpm ERR! gyp info spawn args\nnpm ERR! [\nnpm ERR! gyp info\nnpm ERR! spawn args\nnpm ERR! '/usr/local/lib/node_modules/npm/node_modules/node-gyp/gyp/gyp_main.py',\nnpm ERR! gyp\nnpm ERR! info spawn args   'binding.gyp',\nnpm ERR! gyp info\nnpm ERR! \nnpm ERR! spawn args\nnpm ERR! '-f',\nnpm ERR! gyp\nnpm ERR! \nnpm ERR! info\nnpm ERR! \nnpm ERR! spawn args\nnpm ERR! 'make',\nnpm ERR! gyp\nnpm ERR! \nnpm ERR! info\nnpm ERR! \nnpm ERR! spawn args\nnpm ERR! '-I',\nnpm ERR! gyp\nnpm ERR! \nnpm ERR! info spawn args   '/usr/local/lib/node_modules/generator-basalt/node_modules/nodegit/build/config.gypi',\nnpm ERR! gyp\nnpm ERR! \nnpm ERR! info\nnpm ERR! \nnpm ERR! spawn args\nnpm ERR! '-I',\nnpm ERR! gyp\nnpm ERR! \nnpm ERR! info\nnpm ERR! spawn args   '/usr/local/lib/node_modules/npm/node_modules/node-gyp/addon.gypi',\nnpm ERR! gyp info\nnpm ERR! spawn args\nnpm ERR! '-I',\nnpm ERR! gyp\nnpm ERR! \nnpm ERR! info\nnpm ERR! \nnpm ERR! spawn args\nnpm ERR! '/Users/johe/Library/Caches/node-gyp/16.8.0/include/node/common.gypi',\nnpm ERR! gyp\nnpm ERR! \nnpm ERR! info spawn args\nnpm ERR! '-Dlibrary=shared_library',\nnpm ERR! gyp info spawn args   '-Dvisibility=default',\nnpm ERR! gyp info spawn args\nnpm ERR! '-Dnode_root_dir=/Users/johe/Library/Caches/node-gyp/16.8.0',\nnpm ERR! gyp\nnpm ERR! \nnpm ERR! info\nnpm ERR! \nnpm ERR! spawn args\nnpm ERR! '-Dnode_gyp_dir=/usr/local/lib/node_modules/npm/node_modules/node-gyp',\nnpm ERR! gyp\nnpm ERR! \nnpm ERR! info\nnpm ERR! \nnpm ERR! spawn args\nnpm ERR! '-Dnode_lib_file=/Users/johe/Library/Caches/node-gyp/16.8.0/<(target_arch)/node.lib',\nnpm ERR! gyp\nnpm ERR! \nnpm ERR! info spawn args   '-Dmodule_root_dir=/usr/local/lib/node_modules/generator-basalt/node_modules/nodegit',\nnpm ERR! gyp\nnpm ERR! \nnpm ERR! info\nnpm ERR! \nnpm ERR! spawn args\nnpm ERR! '-Dnode_engine=v8',\nnpm ERR! gyp\nnpm ERR! \nnpm ERR! info\nnpm ERR! spawn args   '--depth=.',\nnpm ERR! gyp\nnpm ERR! \nnpm ERR! info\nnpm ERR! \nnpm ERR! spawn args\nnpm ERR! '--no-parallel',\nnpm ERR! gyp\nnpm ERR! \nnpm ERR! info\nnpm ERR! \nnpm ERR! spawn args\nnpm ERR! '--generator-output',\nnpm ERR! gyp info\nnpm ERR! spawn args\nnpm ERR! 'build',\nnpm ERR! gyp\nnpm ERR! \nnpm ERR! info\nnpm ERR! \nnpm ERR! spawn args\nnpm ERR! '-Goutput_dir=.'\nnpm ERR! gyp\nnpm ERR! \nnpm ERR! info spawn args\nnpm ERR! ]\nnpm ERR! gyp info\nnpm ERR! ok\nnpm ERR! gyp\nnpm ERR! info it worked if it ends with ok\nnpm ERR! gyp info\nnpm ERR! using node-gyp@7.1.2\nnpm ERR! gyp info using\nnpm ERR! node@16.8.0 | darwin | x64\nnpm ERR! gyp info spawn make\nnpm ERR! gyp info spawn args [ 'BUILDTYPE=Release', '-C', 'build' ]\nnpm ERR! ../vendor/libssh2/src/bcrypt_pbkdf.c:84:46: warning: expression does not compute the number of elements in this array; element type is 'uint32_t' (aka 'unsigned int'), not 'uint64_t' (aka 'unsigned long long') [-Wsizeof-array-div]\nnpm ERR!         blf_enc(&state, cdata, sizeof(cdata) / sizeof(uint64_t));\nnpm ERR!                                       ~~~~~  ^\nnpm ERR! ../vendor/libssh2/src/bcrypt_pbkdf.c:65:14: note: array 'cdata' declared here\nnpm ERR!     uint32_t cdata[BCRYPT_BLOCKS];\nnpm ERR!              ^\nnpm ERR! ../vendor/libssh2/src/bcrypt_pbkdf.c:84:46: note: place parentheses around the 'sizeof(uint64_t)' expression to silence this warning\nnpm ERR!         blf_enc(&state, cdata, sizeof(cdata) / sizeof(uint64_t));\nnpm ERR!                                              ^\nnpm ERR! 1 warning generated.\nnpm ERR! In file included from ../src/async_baton.cc:1:\nnpm ERR! In file included from ../src/../include/async_baton.h:5:\nnpm ERR! In file included from ../../nan/nan.h:58:\nnpm ERR! In file included from /Users/johe/Library/Caches/node-gyp/16.8.0/include/node/node.h:63:\nnpm ERR! In file included from /Users/johe/Library/Caches/node-gyp/16.8.0/include/node/v8.h:30:\nnpm ERR! /Users/johe/Library/Caches/node-gyp/16.8.0/include/node/v8-internal.h:488:38: error: no template named 'remove_cv_t' in namespace 'std'; did you mean 'remove_cv'?\nnpm ERR!             !std::is_same<Data, std::remove_cv_t<T>>::value>::Perform(data);\nnpm ERR!                                 ~~~~~^~~~~~~~~~~\nnpm ERR!                                      remove_cv\nnpm ERR! /Library/Developer/CommandLineTools/SDKs/MacOSX.sdk/usr/include/c++/v1/type_traits:776:50: note: 'remove_cv' declared here\nnpm ERR! template <class _Tp> struct _LIBCPP_TEMPLATE_VIS remove_cv\nnpm ERR!                                                  ^\nnpm ERR! 1 error generated.\nnpm ERR! make: *** [Release/obj.target/nodegit/src/async_baton.o] Error 1\nnpm ERR! gyp\nnpm ERR! ERR! build error\nnpm ERR! gyp ERR! stack Error: `make` failed with exit code: 2\nnpm ERR! gyp ERR!\nnpm ERR! stack     at ChildProcess.onExit (/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:194:23)\nnpm ERR! gyp ERR! stack     at ChildProcess.emit (node:events:394:28)\nnpm ERR! gyp ERR! stack     at Process.ChildProcess._handle.onexit (node:internal/child_process:290:12)\nnpm ERR! gyp ERR! System Darwin 20.5.0\nnpm ERR! gyp ERR! command \"/usr/local/Cellar/node/16.8.0/bin/node\" \"/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js\" \"build\" \"--fallback-to-build\" \"--module=/usr/local/lib/node_modules/generator-basalt/node_modules/nodegit/build/Release/nodegit.node\" \"--module_name=nodegit\" \"--module_path=/usr/local/lib/node_modules/generator-basalt/node_modules/nodegit/build/Release\" \"--napi_version=8\" \"--node_abi_napi=napi\" \"--napi_build_version=0\" \"--node_napi_label=node-v93\"\nnpm ERR! gyp ERR! cwd /usr/local/lib/node_modules/generator-basalt/node_modules/nodegit\nnpm ERR! gyp ERR!\nnpm ERR! node -v v16.8.0\nnpm ERR! gyp ERR! node-gyp -v v7.1.2\nnpm ERR! gyp\nnpm ERR! ERR! not ok\nnpm ERR! node-pre-gyp ERR!\nnpm ERR! build error\nnpm ERR! node-pre-gyp ERR! stack Error: Failed to execute '/usr/local/Cellar/node/16.8.0/bin/node /usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js build --fallback-to-build --module=/usr/local/lib/node_modules/generator-basalt/node_modules/nodegit/build/Release/nodegit.node --module_name=nodegit --module_path=/usr/local/lib/node_modules/generator-basalt/node_modules/nodegit/build/Release --napi_version=8 --node_abi_napi=napi --napi_build_version=0 --node_napi_label=node-v93' (1)\nnpm ERR! node-pre-gyp ERR! stack     at ChildProcess.<anonymous> (/usr/local/lib/node_modules/generator-basalt/node_modules/node-pre-gyp/lib/util/compile.js:83:29)\nnpm ERR! node-pre-gyp ERR! stack     at ChildProcess.emit (node:events:394:28)\nnpm ERR! node-pre-gyp ERR!\nnpm ERR! stack     at maybeClose (node:internal/child_process:1064:16)\nnpm ERR! node-pre-gyp ERR! stack     at Process.ChildProcess._handle.onexit (node:internal/child_process:301:5)\nnpm ERR! node-pre-gyp\nnpm ERR! ERR! System Darwin 20.5.0\nnpm ERR! node-pre-gyp ERR!\nnpm ERR! command \"/usr/local/Cellar/node/16.8.0/bin/node\" \"/usr/local/lib/node_modules/generator-basalt/node_modules/.bin/node-pre-gyp\" \"install\" \"--fallback-to-build\"\nnpm ERR! node-pre-gyp ERR! cwd /usr/local/lib/node_modules/generator-basalt/node_modules/nodegit\nnpm ERR! node-pre-gyp ERR! node -v v16.8.0\nnpm ERR! node-pre-gyp ERR!\nnpm ERR! node-pre-gyp -v v0.13.0\nnpm ERR! node-pre-gyp ERR! not ok\nnpm ERR! [nodegit] ERROR - Could not finish install\nnpm ERR! [nodegit] ERROR - finished with error code: 1\n\nnpm ERR! A complete log of this run can be found in:\nnpm ERR!     /Users/johe/.npm/_logs/2021-09-02T11_05_00_267Z-debug.log", "stderr_lines": ["npm WARN deprecated urix@0.1.0: Please see https://github.com/lydell/urix#deprecated", "npm WARN deprecated har-validator@5.1.5: this library is no longer supported", "npm WARN deprecated resolve-url@0.2.1: https://github.com/lydell/resolve-url#deprecated", "npm WARN deprecated uuid@3.4.0: Please upgrade  to version 7 or higher.  Older versions may use Math.random() in certain circumstances, which is known to be problematic.  See https://v8.dev/blog/math-random for details.", "npm WARN deprecated request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142", "npm WARN deprecated node-pre-gyp@0.13.0: Please upgrade to @mapbox/node-pre-gyp: the non-scoped node-pre-gyp package is deprecated and only the @mapbox scoped package will recieve updates in the future", "npm ERR! code 1", "npm ERR! path /usr/local/lib/node_modules/generator-basalt/node_modules/nodegit", "npm ERR! command failed", "npm ERR! command sh -c node lifecycleScripts/preinstall && node lifecycleScripts/install", "npm ERR! [nodegit] Running pre-install script", "npm ERR! [nodegit] Running install script", "npm ERR! SOLINK_MODULE(target) Release/acquireOpenSSL.node", "npm ERR! ACTION binding_gyp_configureLibssh2_target_configure .", "npm ERR! [nodegit] Configuring libssh2.", "npm ERR! SOLINK_MODULE(target) Release/configureLibssh2.node", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/allocators/stdalloc.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/commit.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/alloc.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/annotated_commit.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/apply.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/attr_file.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/attr.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/attrcache.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/blame_git.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/blame.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/blob.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/branch.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/buf_text.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/buffer.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/cache.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/checkout.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/cherrypick.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/clone.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/commit_list.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/config_cache.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/config_entries.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/config_file.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/config_mem.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/config_parse.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/config_snapshot.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/config.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/crlf.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/date.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/delta.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/diff_driver.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/diff_file.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/diff_generate.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/diff_parse.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/diff_print.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/diff_stats.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/diff_tform.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/diff_xdiff.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/diff.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/errors.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/fetch.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/fetchhead.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/filebuf.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/futils.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/filter.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/global.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/graph.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/hash.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/hash/sha1/sha1dc/sha1.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/hash/sha1/sha1dc/ubc_check.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/hash/sha1/collisiondetect.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/hashsig.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/ident.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/idxmap.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/ignore.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/index.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/indexer.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/iterator.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/mailmap.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/merge_driver.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/merge_file.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/merge.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/message.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/mwindow.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/net.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/netops.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/notes.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/object_api.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/object.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/odb_loose.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/odb_mempack.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/odb_pack.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/odb.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/offmap.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/oid.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/oidarray.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/oidmap.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/streams/mbedtls.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/streams/openssl.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/streams/registry.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/pack-objects.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/pack.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/parse.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/patch_generate.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/patch_parse.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/patch.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/path.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/pathspec.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/pool.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/posix.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/pqueue.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/proxy.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/push.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/reader.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/rebase.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/refdb_fs.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/refdb.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/reflog.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/refs.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/refspec.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/regexp.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/remote.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/repository.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/reset.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/revert.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/revparse.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/revwalk.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/settings.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/sha1_lookup.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/signature.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/streams/socket.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/sortedcache.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/stash.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/status.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/strmap.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/submodule.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/sysdir.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/tag.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/thread-utils.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/trace.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/trailer.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transaction.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transport.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/cred_helpers.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/cred.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/git.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/local.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/smart_pkt.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/smart_protocol.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/smart.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/ssh.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/tree-cache.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/tree.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/tsort.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/util.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/varint.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/vector.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/wildmatch.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/worktree.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/xdiff/xdiffi.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/xdiff/xemit.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/xdiff/xhistogram.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/xdiff/xmerge.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/xdiff/xpatience.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/xdiff/xprepare.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/xdiff/xutils.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/zstream.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/streams/stransport.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/http.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/auth.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/auth_negotiate.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/transports/auth_ntlm.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/streams/tls.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/unix/map.o", "npm ERR! CC(target) Release/obj.target/libgit2/vendor/libgit2/src/unix/realpath.o", "npm ERR! LIBTOOL-STATIC Release/git2.a", "npm ERR! CC(target) Release/obj.target/zlib/vendor/libgit2/deps/zlib/adler32.o", "npm ERR! CC(target) Release/obj.target/zlib/vendor/libgit2/deps/zlib/crc32.o", "npm ERR! CC(target) Release/obj.target/zlib/vendor/libgit2/deps/zlib/deflate.o", "npm ERR! CC(target) Release/obj.target/zlib/vendor/libgit2/deps/zlib/inffast.o", "npm ERR! CC(target) Release/obj.target/zlib/vendor/libgit2/deps/zlib/inflate.o", "npm ERR! CC(target) Release/obj.target/zlib/vendor/libgit2/deps/zlib/inftrees.o", "npm ERR! CC(target) Release/obj.target/zlib/vendor/libgit2/deps/zlib/trees.o", "npm ERR! CC(target) Release/obj.target/zlib/vendor/libgit2/deps/zlib/zutil.o", "npm ERR! LIBTOOL-STATIC Release/zlib.a", "npm ERR! CC(target) Release/obj.target/http_parser/vendor/http_parser/http_parser.o", "npm ERR! LIBTOOL-STATIC Release/http_parser.a", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/agent.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/bcrypt_pbkdf.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/blowfish.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/crypt.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/keepalive.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/libgcrypt.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/openssl.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/publickey.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/sftp.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/version.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/channel.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/global.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/kex.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/mac.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/packet.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/scp.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/transport.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/comp.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/hostkey.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/knownhost.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/misc.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/pem.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/session.o", "npm ERR! CC(target) Release/obj.target/libssh2/vendor/libssh2/src/userauth.o", "npm ERR! LIBTOOL-STATIC Release/ssh2.a", "npm ERR! CC(target) Release/obj.target/ntlmclient/vendor/libgit2/deps/ntlmclient/ntlm.o", "npm ERR! CC(target) Release/obj.target/ntlmclient/vendor/libgit2/deps/ntlmclient/unicode_builtin.o", "npm ERR! CC(target) Release/obj.target/ntlmclient/vendor/libgit2/deps/ntlmclient/util.o", "npm ERR! CC(target) Release/obj.target/ntlmclient/vendor/libgit2/deps/ntlmclient/crypt_commoncrypto.o", "npm ERR! LIBTOOL-STATIC Release/ntlmclient.a", "npm ERR! CXX(target) Release/obj.target/nodegit/src/async_baton.o", "npm ERR! Failed to execute '/usr/local/Cellar/node/16.8.0/bin/node /usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js build --fallback-to-build --module=/usr/local/lib/node_modules/generator-basalt/node_modules/nodegit/build/Release/nodegit.node --module_name=nodegit --module_path=/usr/local/lib/node_modules/generator-basalt/node_modules/nodegit/build/Release --napi_version=8 --node_abi_napi=napi --napi_build_version=0 --node_napi_label=node-v93' (1)", "npm ERR! node-pre-gyp", "npm ERR! info it worked if it ends with ok", "npm ERR! node-pre-gyp info using node-pre-gyp@0.13.0", "npm ERR! node-pre-gyp info using node@16.8.0 | darwin | x64", "npm ERR! node-pre-gyp WARN", "npm ERR! Using request for node-pre-gyp https download", "npm ERR! node-pre-gyp info", "npm ERR! check checked for \"/usr/local/lib/node_modules/generator-basalt/node_modules/nodegit/build/Release/nodegit.node\" (not found)", "npm ERR! node-pre-gyp", "npm ERR! http GET https://axonodegit.s3.amazonaws.com/nodegit/nodegit/nodegit-v0.27.0-node-v93-darwin-x64.tar.gz", "npm ERR! node-pre-gyp", "npm ERR! WARN Pre-built binaries not installable for nodegit@0.27.0 and node@16.8.0 (node-v93 ABI, unknown) (falling back to source compile with node-gyp) ", "npm ERR! node-pre-gyp WARN Hit error unable to get local issuer certificate", "npm ERR! gyp", "npm ERR! ", "npm ERR! info it worked if it ends with", "npm ERR! ok", "npm ERR! gyp", "npm ERR! info using node-gyp@7.1.2", "npm ERR! gyp", "npm ERR! ", "npm ERR! info", "npm ERR! ", "npm ERR! using", "npm ERR! node@16.8.0 | darwin | x64", "npm ERR! gyp", "npm ERR! info ok", "npm ERR! gyp", "npm ERR! info it worked if it ends with ok", "npm ERR! gyp", "npm ERR! info using node-gyp@7.1.2", "npm ERR! gyp info using node@16.8.0 | darwin | x64", "npm ERR! gyp info find Python", "npm ERR! using Python version 3.9.6 found at \"/Users/johe/.venv/default/bin/python3\"", "npm ERR! (node:57031) [DEP0150] DeprecationWarning: Setting process.config is deprecated. In the future the property will be read-only.", "npm ERR! (Use `node --trace-deprecation ...` to show where the warning was created)", "npm ERR! gyp", "npm ERR! ", "npm ERR! info", "npm ERR! ", "npm ERR! spawn", "npm ERR! /Users/johe/.venv/default/bin/python3", "npm ERR! gyp info spawn args", "npm ERR! [", "npm ERR! gyp info", "npm ERR! spawn args", "npm ERR! '/usr/local/lib/node_modules/npm/node_modules/node-gyp/gyp/gyp_main.py',", "npm ERR! gyp", "npm ERR! info spawn args   'binding.gyp',", "npm ERR! gyp info", "npm ERR! ", "npm ERR! spawn args", "npm ERR! '-f',", "npm ERR! gyp", "npm ERR! ", "npm ERR! info", "npm ERR! ", "npm ERR! spawn args", "npm ERR! 'make',", "npm ERR! gyp", "npm ERR! ", "npm ERR! info", "npm ERR! ", "npm ERR! spawn args", "npm ERR! '-I',", "npm ERR! gyp", "npm ERR! ", "npm ERR! info spawn args   '/usr/local/lib/node_modules/generator-basalt/node_modules/nodegit/build/config.gypi',", "npm ERR! gyp", "npm ERR! ", "npm ERR! info", "npm ERR! ", "npm ERR! spawn args", "npm ERR! '-I',", "npm ERR! gyp", "npm ERR! ", "npm ERR! info", "npm ERR! spawn args   '/usr/local/lib/node_modules/npm/node_modules/node-gyp/addon.gypi',", "npm ERR! gyp info", "npm ERR! spawn args", "npm ERR! '-I',", "npm ERR! gyp", "npm ERR! ", "npm ERR! info", "npm ERR! ", "npm ERR! spawn args", "npm ERR! '/Users/johe/Library/Caches/node-gyp/16.8.0/include/node/common.gypi',", "npm ERR! gyp", "npm ERR! ", "npm ERR! info spawn args", "npm ERR! '-Dlibrary=shared_library',", "npm ERR! gyp info spawn args   '-Dvisibility=default',", "npm ERR! gyp info spawn args", "npm ERR! '-Dnode_root_dir=/Users/johe/Library/Caches/node-gyp/16.8.0',", "npm ERR! gyp", "npm ERR! ", "npm ERR! info", "npm ERR! ", "npm ERR! spawn args", "npm ERR! '-Dnode_gyp_dir=/usr/local/lib/node_modules/npm/node_modules/node-gyp',", "npm ERR! gyp", "npm ERR! ", "npm ERR! info", "npm ERR! ", "npm ERR! spawn args", "npm ERR! '-Dnode_lib_file=/Users/johe/Library/Caches/node-gyp/16.8.0/<(target_arch)/node.lib',", "npm ERR! gyp", "npm ERR! ", "npm ERR! info spawn args   '-Dmodule_root_dir=/usr/local/lib/node_modules/generator-basalt/node_modules/nodegit',", "npm ERR! gyp", "npm ERR! ", "npm ERR! info", "npm ERR! ", "npm ERR! spawn args", "npm ERR! '-Dnode_engine=v8',", "npm ERR! gyp", "npm ERR! ", "npm ERR! info", "npm ERR! spawn args   '--depth=.',", "npm ERR! gyp", "npm ERR! ", "npm ERR! info", "npm ERR! ", "npm ERR! spawn args", "npm ERR! '--no-parallel',", "npm ERR! gyp", "npm ERR! ", "npm ERR! info", "npm ERR! ", "npm ERR! spawn args", "npm ERR! '--generator-output',", "npm ERR! gyp info", "npm ERR! spawn args", "npm ERR! 'build',", "npm ERR! gyp", "npm ERR! ", "npm ERR! info", "npm ERR! ", "npm ERR! spawn args", "npm ERR! '-Goutput_dir=.'", "npm ERR! gyp", "npm ERR! ", "npm ERR! info spawn args", "npm ERR! ]", "npm ERR! gyp info", "npm ERR! ok", "npm ERR! gyp", "npm ERR! info it worked if it ends with ok", "npm ERR! gyp info", "npm ERR! using node-gyp@7.1.2", "npm ERR! gyp info using", "npm ERR! node@16.8.0 | darwin | x64", "npm ERR! gyp info spawn make", "npm ERR! gyp info spawn args [ 'BUILDTYPE=Release', '-C', 'build' ]", "npm ERR! ../vendor/libssh2/src/bcrypt_pbkdf.c:84:46: warning: expression does not compute the number of elements in this array; element type is 'uint32_t' (aka 'unsigned int'), not 'uint64_t' (aka 'unsigned long long') [-Wsizeof-array-div]", "npm ERR!         blf_enc(&state, cdata, sizeof(cdata) / sizeof(uint64_t));", "npm ERR!                                       ~~~~~  ^", "npm ERR! ../vendor/libssh2/src/bcrypt_pbkdf.c:65:14: note: array 'cdata' declared here", "npm ERR!     uint32_t cdata[BCRYPT_BLOCKS];", "npm ERR!              ^", "npm ERR! ../vendor/libssh2/src/bcrypt_pbkdf.c:84:46: note: place parentheses around the 'sizeof(uint64_t)' expression to silence this warning", "npm ERR!         blf_enc(&state, cdata, sizeof(cdata) / sizeof(uint64_t));", "npm ERR!                                              ^", "npm ERR! 1 warning generated.", "npm ERR! In file included from ../src/async_baton.cc:1:", "npm ERR! In file included from ../src/../include/async_baton.h:5:", "npm ERR! In file included from ../../nan/nan.h:58:", "npm ERR! In file included from /Users/johe/Library/Caches/node-gyp/16.8.0/include/node/node.h:63:", "npm ERR! In file included from /Users/johe/Library/Caches/node-gyp/16.8.0/include/node/v8.h:30:", "npm ERR! /Users/johe/Library/Caches/node-gyp/16.8.0/include/node/v8-internal.h:488:38: error: no template named 'remove_cv_t' in namespace 'std'; did you mean 'remove_cv'?", "npm ERR!             !std::is_same<Data, std::remove_cv_t<T>>::value>::Perform(data);", "npm ERR!                                 ~~~~~^~~~~~~~~~~", "npm ERR!                                      remove_cv", "npm ERR! /Library/Developer/CommandLineTools/SDKs/MacOSX.sdk/usr/include/c++/v1/type_traits:776:50: note: 'remove_cv' declared here", "npm ERR! template <class _Tp> struct _LIBCPP_TEMPLATE_VIS remove_cv", "npm ERR!                                                  ^", "npm ERR! 1 error generated.", "npm ERR! make: *** [Release/obj.target/nodegit/src/async_baton.o] Error 1", "npm ERR! gyp", "npm ERR! ERR! build error", "npm ERR! gyp ERR! stack Error: `make` failed with exit code: 2", "npm ERR! gyp ERR!", "npm ERR! stack     at ChildProcess.onExit (/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:194:23)", "npm ERR! gyp ERR! stack     at ChildProcess.emit (node:events:394:28)", "npm ERR! gyp ERR! stack     at Process.ChildProcess._handle.onexit (node:internal/child_process:290:12)", "npm ERR! gyp ERR! System Darwin 20.5.0", "npm ERR! gyp ERR! command \"/usr/local/Cellar/node/16.8.0/bin/node\" \"/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js\" \"build\" \"--fallback-to-build\" \"--module=/usr/local/lib/node_modules/generator-basalt/node_modules/nodegit/build/Release/nodegit.node\" \"--module_name=nodegit\" \"--module_path=/usr/local/lib/node_modules/generator-basalt/node_modules/nodegit/build/Release\" \"--napi_version=8\" \"--node_abi_napi=napi\" \"--napi_build_version=0\" \"--node_napi_label=node-v93\"", "npm ERR! gyp ERR! cwd /usr/local/lib/node_modules/generator-basalt/node_modules/nodegit", "npm ERR! gyp ERR!", "npm ERR! node -v v16.8.0", "npm ERR! gyp ERR! node-gyp -v v7.1.2", "npm ERR! gyp", "npm ERR! ERR! not ok", "npm ERR! node-pre-gyp ERR!", "npm ERR! build error", "npm ERR! node-pre-gyp ERR! stack Error: Failed to execute '/usr/local/Cellar/node/16.8.0/bin/node /usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js build --fallback-to-build --module=/usr/local/lib/node_modules/generator-basalt/node_modules/nodegit/build/Release/nodegit.node --module_name=nodegit --module_path=/usr/local/lib/node_modules/generator-basalt/node_modules/nodegit/build/Release --napi_version=8 --node_abi_napi=napi --napi_build_version=0 --node_napi_label=node-v93' (1)", "npm ERR! node-pre-gyp ERR! stack     at ChildProcess.<anonymous> (/usr/local/lib/node_modules/generator-basalt/node_modules/node-pre-gyp/lib/util/compile.js:83:29)", "npm ERR! node-pre-gyp ERR! stack     at ChildProcess.emit (node:events:394:28)", "npm ERR! node-pre-gyp ERR!", "npm ERR! stack     at maybeClose (node:internal/child_process:1064:16)", "npm ERR! node-pre-gyp ERR! stack     at Process.ChildProcess._handle.onexit (node:internal/child_process:301:5)", "npm ERR! node-pre-gyp", "npm ERR! ERR! System Darwin 20.5.0", "npm ERR! node-pre-gyp ERR!", "npm ERR! command \"/usr/local/Cellar/node/16.8.0/bin/node\" \"/usr/local/lib/node_modules/generator-basalt/node_modules/.bin/node-pre-gyp\" \"install\" \"--fallback-to-build\"", "npm ERR! node-pre-gyp ERR! cwd /usr/local/lib/node_modules/generator-basalt/node_modules/nodegit", "npm ERR! node-pre-gyp ERR! node -v v16.8.0", "npm ERR! node-pre-gyp ERR!", "npm ERR! node-pre-gyp -v v0.13.0", "npm ERR! node-pre-gyp ERR! not ok", "npm ERR! [nodegit] ERROR - Could not finish install", "npm ERR! [nodegit] ERROR - finished with error code: 1", "", "npm ERR! A complete log of this run can be found in:", "npm ERR!     /Users/johe/.npm/_logs/2021-09-02T11_05_00_267Z-debug.log"], "stdout": "", "stdout_lines": []}