Untitled

mail@pastecode.io avatar
unknown
plain_text
a year ago
1.8 kB
0
Indexable
Never
&НаСервере
Процедура ЗаполнитьНаСервере()
	
	// Получение остатков по регистру Расчеты с сотрудниками с отбором по подразделению
	Объект.СписокСотрудников.Очистить();
	
	Запрос = Новый Запрос;
	Запрос.Текст = 
	"ВЫБРАТЬ
	|	РасчетыССотрудникамиОстатки.Сотрудник,
	|	РасчетыССотрудникамиОстатки.ВидРасчета,
	|	РасчетыССотрудникамиОстатки.СуммаОстаток КАК Сумма
	|ИЗ
	|	РегистрНакопления.РасчетыССотрудниками.Остатки(&МоментВремени, Подразделение = &Подразделение) КАК РасчетыССотрудникамиОстатки";
	
	Запрос.УстановитьПараметр("Подразделение", Объект.Подразделение);   
	Запрос.УстановитьПараметр("МоментВремени", РеквизитФормыВЗначение("Объект").МоментВремени());   
	
	// Заполнение табличной части полученными данными
	Выборка = Запрос.Выполнить().Выбрать();
	Пока Выборка.Следующий() Цикл
		НоваяСтрока = Объект.СписокСотрудников.Добавить();
		ЗаполнитьЗначенияСвойств(НоваяСтрока, Выборка);
	КонецЦикла;
	
КонецПроцедуры

&НаКлиенте
Процедура Заполнить(Команда)
	ЗаполнитьНаСервере();
КонецПроцедуры