Média ponderada

 avatar
hercioneto
plain_text
a month ago
745 B
3
Indexable
Never
Algoritmo MediaPonderada
 float: prova1, prova2, prova3,media, somaProvas, somaPesos, pesoProva1,pesoProva2,pesoProva3;

pesoProva1 = 2;
pesoProva2 = 3;
pesoProva3 = 5;
 
escreva ("Digite a nota da prova 1:");
 leia prova1;

escreva ("Digite a nota da prova 2:");
 leia prova2;

escreva ("Digite a nota da prova 3:");
 leia prova3;

prova1 = prova1*pesoProva1;
prova2 = prova2*pesoProva2;
prova3 = prova3*pesoProva3;

somaProvas = prova1+prova2+prova3;
somaPesos = pesoProva1+pesoProva2+pesoProva3;

media = somaProvas / somaPesos;

se (media > 8) entao
 escreva ("Parabéns!");
fim se

se (media < 5) entao
 escreva ("Procure se esforçar mais");
fim se

escreva ("Media das provas:");
escreva (media);

fim.
Leave a Comment