Untitled

mail@pastecode.io avatar
unknown
plain_text
a year ago
1.8 kB
0
Indexable
Never
Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
	СуммаДокумента = СписокНоменклатуры.Итог("Сумма");
КонецПроцедуры


Процедура ОбработкаПроведенияБУ(Отказ)
	
	// ДВИЖЕНИЯ ПО РЕГИСТРУ УПРАВЛЕНЧЕСКИЙ
	
	Движения.Управленческий.Записывать = Истина;
	
	СтруктураОтбора = Новый Структура ("Валюта", Договор.Валюта);
	КурсВалюты = РегистрыСведений.КурсыВалют.ПолучитьПоследнее(Дата, СтруктураОтбора).Курс;
	Если Не ЗначениеЗаполнено(КурсВалюты) Тогда
		КурсВалюты = 1;
	КонецЕсли;
	
	Проводка = Движения.Управленческий.Добавить();
	Проводка.Период = Дата;
	Проводка.СчетДт = ПланыСчетов.Управленческий.Покупатели;
	Проводка.СчетКт = ПланыСчетов.Управленческий.ПрибылиУбытки;
	Проводка.СубконтоДт[ПланыВидовХарактеристик.ВидыСубконто.Контрагенты] = Контрагент;
	Проводка.СубконтоДт[ПланыВидовХарактеристик.ВидыСубконто.Договоры] = Договор;
	Проводка.СуммаВалютнаяДт = СуммаДокумента;
	Проводка.Сумма = СуммаДокумента * КурсВалюты;
	
КонецПроцедуры