Untitled

mail@pastecode.io avatar
unknown
json
a year ago
7.3 kB
10
Indexable
Never
[10:50:42.395] Running build in Cleveland, USA (East) – cle1
[10:50:42.458] Cloning github.com/Timeswap-Labs/Timeswap-V2-Monorepo (Branch: main, Commit: 6ea2335)
[10:50:42.722] Previous build cache not available
[10:50:44.494] Warning: Failed to fetch one or more git submodules
[10:50:44.495] Cloning completed: 2.037s
[10:50:44.860] Running "vercel build"
[10:50:45.370] Vercel CLI 30.2.1
[10:50:45.977] Running "install" command: `yarn install`...
[10:50:46.267] yarn install v1.22.17
[10:50:46.378] warning package-lock.json found. Your project contains lock files generated by tools other than Yarn. It is advised not to mix package managers in order to avoid resolution inconsistencies caused by unsynchronized lock files. To clear this warning, remove package-lock.json.
[10:50:46.418] [1/4] Resolving packages...
[10:50:46.903] [2/4] Fetching packages...
[10:51:10.484] warning abitype@0.3.0: The engine "pnpm" appears to be invalid.
[10:51:10.492] [3/4] Linking dependencies...
[10:51:10.496] warning "workspace-aggregator-07b2e6da-e43b-45d9-b1d2-4810458614f7 > @timeswap-labs/v2-library > hardhat-gas-reporter@1.0.9" has unmet peer dependency "hardhat@^2.0.2".
[10:51:10.496] warning "workspace-aggregator-07b2e6da-e43b-45d9-b1d2-4810458614f7 > @timeswap-labs/v2-library > mocha-chai-jest-snapshot@1.1.4" has unmet peer dependency "chai@^4.3.6".
[10:51:10.496] warning "workspace-aggregator-07b2e6da-e43b-45d9-b1d2-4810458614f7 > @timeswap-labs/v2-periphery-nodex > @nomicfoundation/hardhat-chai-matchers@1.0.6" has unmet peer dependency "@nomiclabs/hardhat-ethers@^2.0.0".
[10:51:10.496] warning "workspace-aggregator-07b2e6da-e43b-45d9-b1d2-4810458614f7 > @timeswap-labs/v2-periphery-nodex > @nomicfoundation/hardhat-chai-matchers@1.0.6" has unmet peer dependency "chai@^4.2.0".
[10:51:10.496] warning "workspace-aggregator-07b2e6da-e43b-45d9-b1d2-4810458614f7 > @timeswap-labs/v2-periphery-nodex > @nomicfoundation/hardhat-chai-matchers@1.0.6" has unmet peer dependency "ethers@^5.0.0".
[10:51:10.497] warning "workspace-aggregator-07b2e6da-e43b-45d9-b1d2-4810458614f7 > @timeswap-labs/v2-periphery-nodex > @nomicfoundation/hardhat-toolbox@2.0.2" has unmet peer dependency "@ethersproject/abi@^5.4.7".
[10:51:10.497] warning "workspace-aggregator-07b2e6da-e43b-45d9-b1d2-4810458614f7 > @timeswap-labs/v2-periphery-nodex > @nomicfoundation/hardhat-toolbox@2.0.2" has unmet peer dependency "@ethersproject/providers@^5.4.7".
[10:51:10.497] warning "workspace-aggregator-07b2e6da-e43b-45d9-b1d2-4810458614f7 > @timeswap-labs/v2-periphery-nodex > @nomicfoundation/hardhat-toolbox@2.0.2" has unmet peer dependency "@nomicfoundation/hardhat-network-helpers@^1.0.0".
[10:51:10.498] warning "workspace-aggregator-07b2e6da-e43b-45d9-b1d2-4810458614f7 > @timeswap-labs/v2-periphery-nodex > @nomicfoundation/hardhat-toolbox@2.0.2" has unmet peer dependency "@nomiclabs/hardhat-ethers@^2.0.0".
[10:51:10.498] warning "workspace-aggregator-07b2e6da-e43b-45d9-b1d2-4810458614f7 > @timeswap-labs/v2-periphery-nodex > @nomicfoundation/hardhat-toolbox@2.0.2" has unmet peer dependency "@nomiclabs/hardhat-etherscan@^3.0.0".
[10:51:10.498] warning "workspace-aggregator-07b2e6da-e43b-45d9-b1d2-4810458614f7 > @timeswap-labs/v2-periphery-nodex > @nomicfoundation/hardhat-toolbox@2.0.2" has unmet peer dependency "@types/chai@^4.2.0".
[10:51:10.499] warning "workspace-aggregator-07b2e6da-e43b-45d9-b1d2-4810458614f7 > @timeswap-labs/v2-periphery-nodex > @nomicfoundation/hardhat-toolbox@2.0.2" has unmet peer dependency "@types/mocha@>=9.1.0".
[10:51:10.499] warning "workspace-aggregator-07b2e6da-e43b-45d9-b1d2-4810458614f7 > @timeswap-labs/v2-periphery-nodex > @nomicfoundation/hardhat-toolbox@2.0.2" has unmet peer dependency "@types/node@>=12.0.0".
[10:51:10.499] warning "workspace-aggregator-07b2e6da-e43b-45d9-b1d2-4810458614f7 > @timeswap-labs/v2-periphery-nodex > @nomicfoundation/hardhat-toolbox@2.0.2" has unmet peer dependency "@typechain/ethers-v5@^10.1.0".
[10:51:10.499] warning "workspace-aggregator-07b2e6da-e43b-45d9-b1d2-4810458614f7 > @timeswap-labs/v2-periphery-nodex > @nomicfoundation/hardhat-toolbox@2.0.2" has unmet peer dependency "@typechain/hardhat@^6.1.2".
[10:51:10.501] warning "workspace-aggregator-07b2e6da-e43b-45d9-b1d2-4810458614f7 > @timeswap-labs/v2-periphery-nodex > @nomicfoundation/hardhat-toolbox@2.0.2" has unmet peer dependency "chai@^4.2.0".
[10:51:10.501] warning "workspace-aggregator-07b2e6da-e43b-45d9-b1d2-4810458614f7 > @timeswap-labs/v2-periphery-nodex > @nomicfoundation/hardhat-toolbox@2.0.2" has unmet peer dependency "ethers@^5.4.7".
[10:51:10.501] warning "workspace-aggregator-07b2e6da-e43b-45d9-b1d2-4810458614f7 > @timeswap-labs/v2-periphery-nodex > @nomicfoundation/hardhat-toolbox@2.0.2" has unmet peer dependency "hardhat-gas-reporter@^1.0.8".
[10:51:10.501] warning "workspace-aggregator-07b2e6da-e43b-45d9-b1d2-4810458614f7 > @timeswap-labs/v2-periphery-nodex > @nomicfoundation/hardhat-toolbox@2.0.2" has unmet peer dependency "solidity-coverage@^0.8.1".
[10:51:10.501] warning "workspace-aggregator-07b2e6da-e43b-45d9-b1d2-4810458614f7 > @timeswap-labs/v2-periphery-nodex > @nomicfoundation/hardhat-toolbox@2.0.2" has unmet peer dependency "ts-node@>=8.0.0".
[10:51:10.501] warning "workspace-aggregator-07b2e6da-e43b-45d9-b1d2-4810458614f7 > @timeswap-labs/v2-periphery-nodex > @nomicfoundation/hardhat-toolbox@2.0.2" has unmet peer dependency "typechain@^8.1.0".
[10:51:10.501] warning "workspace-aggregator-07b2e6da-e43b-45d9-b1d2-4810458614f7 > @timeswap-labs/v2-periphery-nodex > @nomicfoundation/hardhat-toolbox@2.0.2" has unmet peer dependency "typescript@>=4.5.0".
[10:51:10.502] warning "workspace-aggregator-07b2e6da-e43b-45d9-b1d2-4810458614f7 > @timeswap-labs/v2-frontend > @web3modal/ethereum@2.3.7" has unmet peer dependency "@wagmi/core@>=0.10".
[10:51:10.502] warning "workspace-aggregator-07b2e6da-e43b-45d9-b1d2-4810458614f7 > @timeswap-labs/v2-frontend > babel-eslint@10.1.0" has unmet peer dependency "eslint@>= 4.12.1".
[10:51:10.502] warning "workspace-aggregator-07b2e6da-e43b-45d9-b1d2-4810458614f7 > @timeswap-labs/v2-frontend > react-lottie@1.2.3" has incorrect peer dependency "react@^0.14.7 || ^15.0.0 || ^16.0.0".
[10:51:10.502] warning "workspace-aggregator-07b2e6da-e43b-45d9-b1d2-4810458614f7 > @timeswap-labs/v2-frontend > react-moment@1.1.3" has unmet peer dependency "prop-types@^15.7.0".
[10:51:10.502] warning "workspace-aggregator-07b2e6da-e43b-45d9-b1d2-4810458614f7 > @timeswap-labs/v2-periphery-nodex > @nomicfoundation/hardhat-chai-matchers > chai-as-promised@7.1.1" has unmet peer dependency "chai@>= 2.1.2 < 5".
[10:51:10.502] warning "workspace-aggregator-07b2e6da-e43b-45d9-b1d2-4810458614f7 > @timeswap-labs/v2-frontend > wagmi > abitype@0.3.0" has unmet peer dependency "typescript@>=4.9.4".
[10:51:32.695] [4/4] Building fresh packages...
[10:51:36.869] success Saved lockfile.
[10:51:36.872] Done in 50.61s.
[10:51:37.160] yarn run v1.22.17
[10:51:37.207] error Command "lerna" not found.
[10:51:37.207] info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.
[10:51:37.226] Error: Command "yarn lerna run buildVercel" exited with 1
[10:51:37.765] BUILD_UTILS_SPAWN_1: Command "yarn lerna run buildVercel" exited with 1