Untitled

mail@pastecode.io avatar
unknown
plain_text
2 months ago
124 kB
1
Indexable
Never
Функция СведенияОВнешнейОбработке() Экспорт
	
	Инфо = Новый Структура;
	
	Инфо.Вставить("Вид",             "ПечатнаяФорма");
	Инфо.Вставить("Команды",         Новый ТаблицаЗначений);
	Инфо.Вставить("БезопасныйРежим", Истина);
	Инфо.Вставить("Назначение",      Новый Массив);
	
	Инфо.Вставить("Наименование", НСтр("ru = 'Договор страхования ДВС (печатные формы)'"));
	Инфо.Вставить("Версия",       "1.0");
	Инфо.Вставить("ВерсияБСП",    "1.2.1.4");
	Инфо.Вставить("Информация",    НСтр("ru = 'Договор страхования ДВС (печатные формы)'"));
	
	Колонки = Инфо.Команды.Колонки;
	ТипСтрока = Новый ОписаниеТипов("Строка");
	Колонки.Добавить("Представление", ТипСтрока);
	Колонки.Добавить("Идентификатор", ТипСтрока);
	Колонки.Добавить("Использование", ТипСтрока);
	Колонки.Добавить("Модификатор",   ТипСтрока);
	Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
	
	// Единственная команда, что делать - определяем по типу переданного.
	Команда = Инфо.Команды.Добавить();
	Команда.Представление = НСтр("ru = 'Печать договора страхования'");
	Команда.Идентификатор = "ПечатьДоговораСтрахованияДВС";
	Команда.Использование = "ВызовСерверногоМетода";
	
	Возврат Инфо;
	
КонецФункции

Функция ПолучитьПечатнуюФорму_ДокторВДорогу_СпросиУЮриста(ОбъектНазначения) Экспорт 
	
	ТабличныйДокумент = Новый ТабличныйДокумент;
	
	Запрос = Новый Запрос;
	Запрос.Текст =
	"ВЫБРАТЬ
	|	НастройкиСтраховыхПродуктовСрезПоследних.СуммаПремии КАК СуммаПремии,
	|	НастройкиСтраховыхПродуктовСрезПоследних.СтраховойПродукт КАК СтраховойПродукт,
	|	НастройкиСтраховыхПродуктовСрезПоследних.КраткоеОписание КАК КраткоеОписание
	|ПОМЕСТИТЬ ВТ_НастройкиСтраховыхПродуктов
	|ИЗ
	|	РегистрСведений.НастройкиСтраховыхПродуктов.СрезПоследних КАК НастройкиСтраховыхПродуктовСрезПоследних
	|;
	|
	|////////////////////////////////////////////////////////////////////////////////
	|ВЫБРАТЬ
	|	ДоговорыСтрахованияДВС.СтраховойПродукт КАК СтраховойПродукт,
	|	ДоговорыСтрахованияДВС.Страхователь КАК Страхователь,
	|	СертификатыСтраховыхПрограмм.НомерСертификата КАК НомерСертификата,
	|	СертификатыСтраховыхПрограмм.КодАктивации КАК КодАктивации,
	|	ДоговорыСтрахованияДВС.ДатаНачала КАК ДатаНачала,
	|	ДоговорыСтрахованияДВС.СуммаПремии КАК СуммаПремии,
	|	ВТ_НастройкиСтраховыхПродуктов.КраткоеОписание КАК КраткоеОписание
	|ИЗ
	|	Документ.ДоговорСтрахованияДВС КАК ДоговорыСтрахованияДВС
	|		ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрСведений.СертификатыСтраховыхПрограмм КАК СертификатыСтраховыхПрограмм
	|			ВНУТРЕННЕЕ СОЕДИНЕНИЕ ВТ_НастройкиСтраховыхПродуктов КАК ВТ_НастройкиСтраховыхПродуктов
	|			ПО СертификатыСтраховыхПрограмм.СтраховойПродукт = ВТ_НастройкиСтраховыхПродуктов.СтраховойПродукт
	|				И СертификатыСтраховыхПрограмм.СуммаПремии = ВТ_НастройкиСтраховыхПродуктов.СуммаПремии
	|		ПО ДоговорыСтрахованияДВС.Ссылка = СертификатыСтраховыхПрограмм.ДоговорСтрахованияДВС
	|ГДЕ
	|	ДоговорыСтрахованияДВС.Ссылка = &Ссылка";
	
	Запрос.УстановитьПараметр("Ссылка", ОбъектНазначения);
	
	РезультатЗапроса = Запрос.Выполнить();
	Выборка = РезультатЗапроса.Выбрать();
	
	Если Выборка.Следующий() Тогда
		
		Если Выборка.СтраховойПродукт = Справочники.СтраховыеПродукты.ДокторВДорогу Тогда
			Макет = ПолучитьМакет("ДокторВДорогу");
			ИмяБезРасширения = "Сертификат Доктор в дорогу";
		ИначеЕсли Выборка.СтраховойПродукт = Справочники.СтраховыеПродукты.СпросиУЮриста Тогда
			Макет = ПолучитьМакет("СпросиУЮриста");
			ИмяБезРасширения = "Сертификат ЮРИСТ ПОМОЖЕТ";
		Иначе
			ЗаписьЖурналаРегистрации(НСтр("ru = 'Получение внешней печатной формы'", ОбщегоНазначения.КодОсновногоЯзыка()),
			УровеньЖурналаРегистрации.Ошибка, , , "Страховой продукт не идентифицирован");
		КонецЕсли;
		
		ОбластьШапка = Макет.ПолучитьОбласть("Шапка");
		ОбластьУслуга = Макет.ПолучитьОбласть("Услуга");
		ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");
		
		ОбластьШапка.Параметры.СтраховаяПрограмма	= Выборка.КраткоеОписание;
		ОбластьШапка.Параметры.ФИОВладельца			= Выборка.Страхователь;
		ОбластьШапка.Параметры.НомерСертификата		= Выборка.НомерСертификата;
		ОбластьШапка.Параметры.КодАктивации			= Выборка.КодАктивации;
		
		ТабличныйДокумент.Вывести(ОбластьШапка);
		
		НастройкиСтраховыхПрограмм = РегистрыСведений.НастройкиСтраховыхПрограмм.ПолучитьНастройкиСраховыхПрограмм(Выборка.СтраховойПродукт, Выборка.СуммаПремии);
		
		КоличествоУслуг = 0;
		ВысотаТаблицы = ТабличныйДокумент.ВысотаТаблицы;
		
		Для Каждого СтрокаНастройка Из НастройкиСтраховыхПрограмм Цикл
			
			Если СтрокаНастройка.ЗначениеНастройки <> 0 Тогда
				
				Если КоличествоУслуг = 0 Тогда
					
					Если Выборка.СтраховойПродукт = Справочники.СтраховыеПродукты.ДокторВДорогу Тогда
						ОбластьУслуга.Параметры.ТекстУслуги = "Консультации врача";		
					ИначеЕсли Выборка.СтраховойПродукт = Справочники.СтраховыеПродукты.СпросиУЮриста Тогда
						ОбластьУслуга.Параметры.ТекстУслуги = "Юридическая помощь";		
					КонецЕсли;
					
				Иначе
					ОбластьУслуга.Параметры.ТекстУслуги = "";		
				КонецЕсли;
				
				Если СтрокаНастройка.ВидНастройки = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.КоличествоКонсультацийТерапевта Тогда
					ОбластьУслуга.Параметры.ОписаниеУслуги = "Онлайн-консультации терапевта";
				ИначеЕсли СтрокаНастройка.ВидНастройки = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.КоличествоКонсультацийТравматолога Тогда
					ОбластьУслуга.Параметры.ОписаниеУслуги = "Хирург, Невролог,  травматолог";
				ИначеЕсли СтрокаНастройка.ВидНастройки = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.КоличествоУстныхПравовыхКонсультаций Тогда
					ОбластьУслуга.Параметры.ОписаниеУслуги = "Онлайн-консультации юриста";
				ИначеЕсли СтрокаНастройка.ВидНастройки = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.КоличествоЗвонковЮристаОтИмениКлиента Тогда
					ОбластьУслуга.Параметры.ОписаниеУслуги = "Звонок юриста от имени Клиента";
				ИначеЕсли СтрокаНастройка.ВидНастройки = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.КоличествоПодборовЮридическихКомпаний Тогда
					ОбластьУслуга.Параметры.ОписаниеУслуги = "Подбор юридических компаний для очной консультации или представительства в суде";
				ИначеЕсли СтрокаНастройка.ВидНастройки = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.КоличествоПодборовЭкспертныхКомпаний Тогда
					ОбластьУслуга.Параметры.ОписаниеУслуги = "Подбор экспертных компаний для проведения независимой экспертизы";
				ИначеЕсли СтрокаНастройка.ВидНастройки = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.КоличествоПредоставленийТиповыхЮридическихДокументов Тогда
					ОбластьУслуга.Параметры.ОписаниеУслуги = "Предоставление типовых юридических документов";
				ИначеЕсли СтрокаНастройка.ВидНастройки = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.КоличествоБесплатныхЗвонков Тогда
					ОбластьУслуга.Параметры.ОписаниеУслуги = "Бесплатный звонок из любой точки РФ / Доступ в личный кабинет";
				Иначе
					Продолжить;	
				КонецЕсли;
				
				ОбластьУслуга.Параметры.ОбъемУслуги = ПолучитьПредставлениеОбъемаУслуги(СтрокаНастройка.ЗначениеНастройки);
				
				ТабличныйДокумент.Вывести(ОбластьУслуга);
				
				КоличествоУслуг = КоличествоУслуг + 1;
				
			КонецЕсли;
			
		КонецЦикла;
		
		ОбластьПодвал.Параметры.СтоимостьУслуг = Выборка.СуммаПремии;
		ТабличныйДокумент.Вывести(ОбластьПодвал);
		
	КонецЕсли;
	
	Возврат ТабличныйДокумент;
		
КонецФункции

Функция ПолучитьПечатнуюФорму_Автопомощник(ОбъектНазначения) Экспорт 
	
	ТабличныйДокумент = Новый ТабличныйДокумент;
	
	Запрос = Новый Запрос;
	Запрос.Текст =
	"ВЫБРАТЬ
	|	ДоговорыСтрахованияДВС.Страхователь КАК Страхователь,
	|	ДоговорыСтрахованияДВС.Дата КАК ДатаОформления,
	|	СертификатыСтраховыхПрограмм.НомерСертификата КАК НомерСертификата,
	|	СертификатыСтраховыхПрограмм.КодАктивации КАК КодАктивации,
	|	ДоговорыСтрахованияДВС.ДатаНачала КАК ДатаНачала,
	|	СертификатыСтраховыхПрограмм.СуммаПремии КАК СуммаПремии
	|ИЗ
	|	Документ.ДоговорСтрахованияДВС КАК ДоговорыСтрахованияДВС
	|		ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрСведений.СертификатыСтраховыхПрограмм КАК СертификатыСтраховыхПрограмм
	|		ПО ДоговорыСтрахованияДВС.Ссылка = СертификатыСтраховыхПрограмм.ДоговорСтрахованияДВС
	|			И (СертификатыСтраховыхПрограмм.СтраховойПродукт = ЗНАЧЕНИЕ(Справочник.СтраховыеПродукты.СервисАвтопомощник))
	|ГДЕ
	|	ДоговорыСтрахованияДВС.Ссылка = &Ссылка";
	
	Запрос.УстановитьПараметр("Ссылка", ОбъектНазначения);
	
	РезультатЗапроса = Запрос.Выполнить();
	Выборка = РезультатЗапроса.Выбрать();
	
	Если Выборка.Следующий() Тогда
		
		Макет 			= ПолучитьМакет("Автопомощник");			
		ОбластьШапка 	= Макет.ПолучитьОбласть("Шапка");
		ОбластьУслуга 	= Макет.ПолучитьОбласть("Услуга");
		ОбластьПодвал 	= Макет.ПолучитьОбласть("Подвал");
		
		ОбластьШапка.Параметры.ФИОВладельца		= Выборка.Страхователь;
		ОбластьШапка.Параметры.НомерСертификата	= Выборка.НомерСертификата;
		ОбластьШапка.Параметры.КодАктивации		= Выборка.КодАктивации;
		
		ОбластьПодвал.Параметры.ДатаОформления	= Выборка.ДатаОформления;
		ОбластьПодвал.Параметры.СтоимостьУслуг 	= Выборка.СуммаПремии;
			
		ТабличныйДокумент.Вывести(ОбластьШапка);
		ТабличныйДокумент.Вывести(ОбластьУслуга);
		ТабличныйДокумент.Вывести(ОбластьПодвал);
			
	КонецЕсли;
	
	Возврат ТабличныйДокумент;
		
КонецФункции

Функция ПолучитьПечатнуюФорму_АвтопомощникПлюс(ОбъектНазначения) Экспорт 
	
	ТабличныйДокумент = Новый ТабличныйДокумент;
	
	Запрос = Новый Запрос;
	Запрос.Текст =
	"ВЫБРАТЬ
	|	НастройкиСтраховыхПродуктовСрезПоследних.СуммаПремии КАК СуммаПремии,
	|	НастройкиСтраховыхПродуктовСрезПоследних.СтраховойПродукт КАК СтраховойПродукт,
	|	НастройкиСтраховыхПродуктовСрезПоследних.КраткоеОписание КАК КраткоеОписание
	|ПОМЕСТИТЬ ВТ_НастройкиСтраховыхПродуктов
	|ИЗ
	|	РегистрСведений.НастройкиСтраховыхПродуктов.СрезПоследних КАК НастройкиСтраховыхПродуктовСрезПоследних
	|;
	|
	|////////////////////////////////////////////////////////////////////////////////
	|ВЫБРАТЬ
	|	ДоговорыСтрахованияДВС.СтраховойПродукт КАК СтраховойПродукт,
	|	ДоговорыСтрахованияДВС.Страхователь КАК Страхователь,
	|	СертификатыСтраховыхПрограмм.НомерСертификата КАК НомерСертификата,
	|	СертификатыСтраховыхПрограмм.КодАктивации КАК КодАктивации,
	|	ДоговорыСтрахованияДВС.ДатаНачала КАК ДатаНачала,
	|	ДоговорыСтрахованияДВС.СуммаПремии КАК СуммаПремии,
	|	ВТ_НастройкиСтраховыхПродуктов.КраткоеОписание КАК КраткоеОписание,
	|	ВЫБОР
	|		КОГДА ДоговорСтрахования.ТранспортноеСредство_Марка = """"
	|			ТОГДА ""Отсутствует""
	|		ИНАЧЕ ДоговорСтрахования.ТранспортноеСредство_Марка
	|	КОНЕЦ КАК Марка,
	|	ВЫБОР
	|		КОГДА ДоговорСтрахования.ТранспортноеСредство_Модель = """"
	|			ТОГДА ""Отсутствует""
	|		ИНАЧЕ ДоговорСтрахования.ТранспортноеСредство_Модель
	|	КОНЕЦ КАК Модель,
	|	ВЫБОР
	|		КОГДА ДоговорСтрахования.ТранспортноеСредство_VIN = """"
	|			ТОГДА ""Отсутствует""
	|		ИНАЧЕ ДоговорСтрахования.ТранспортноеСредство_VIN
	|	КОНЕЦ КАК VIN,
	|	ВЫБОР
	|		КОГДА ДоговорСтрахования.ТранспортноеСредство_НомерКузова = """"
	|			ТОГДА ""Отсутствует""
	|		ИНАЧЕ ДоговорСтрахования.ТранспортноеСредство_НомерКузова
	|	КОНЕЦ КАК НомерКузова,
	|	ВЫБОР
	|		КОГДА ДоговорСтрахования.ТранспортноеСредство_ГРН = """"
	|			ТОГДА ""Отсутствует""
	|		ИНАЧЕ ДоговорСтрахования.ТранспортноеСредство_ГРН
	|	КОНЕЦ КАК ГРН,
	|	ДоговорыСтрахованияДВС.Дата КАК ДатаОформления,
	|	ВТ_НастройкиСтраховыхПродуктов.КраткоеОписание КАК КраткоеОписание1
	|ИЗ
	|	Документ.ДоговорСтрахованияДВС КАК ДоговорыСтрахованияДВС
	|		ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрСведений.СертификатыСтраховыхПрограмм КАК СертификатыСтраховыхПрограмм
	|			ВНУТРЕННЕЕ СОЕДИНЕНИЕ ВТ_НастройкиСтраховыхПродуктов КАК ВТ_НастройкиСтраховыхПродуктов
	|			ПО СертификатыСтраховыхПрограмм.СтраховойПродукт = ВТ_НастройкиСтраховыхПродуктов.СтраховойПродукт
	|				И СертификатыСтраховыхПрограмм.СуммаПремии = ВТ_НастройкиСтраховыхПродуктов.СуммаПремии
	|		ПО ДоговорыСтрахованияДВС.Ссылка = СертификатыСтраховыхПрограмм.ДоговорСтрахованияДВС
	|		ЛЕВОЕ СОЕДИНЕНИЕ Документ.ДоговорСтрахованияОСАГО КАК ДоговорСтрахования
	|		ПО ДоговорыСтрахованияДВС.ДоговорСтрахованияОСАГО = ДоговорСтрахования.Ссылка
	|ГДЕ
	|	ДоговорыСтрахованияДВС.Ссылка = &Ссылка";
	
	Запрос.УстановитьПараметр("Ссылка", ОбъектНазначения);
	
	РезультатЗапроса = Запрос.Выполнить();
	Выборка = РезультатЗапроса.Выбрать();
	
	Если Выборка.Следующий() Тогда
		
		Макет = ПолучитьМакет("АвтопомощникПлюс");
		
		ОбластьШапка 	= Макет.ПолучитьОбласть("Шапка");
		ОбластьУслуга 	= Макет.ПолучитьОбласть("Услуга");
		ОбластьУслуги 	= Макет.ПолучитьОбласть("Услуги");
		ОбластьПодвал 	= Макет.ПолучитьОбласть("Подвал");
		
		СтраховойПакет 	= ОпределитьСтраховойПакет(Выборка.СуммаПремии, Справочники.СтраховыеПродукты.АвтопомощникПлюс);
		СтраховойПакет 	= СокрЛП(СтраховойПакет);
		МассивСтрок 	= СтрРазделить(СтраховойПакет, Символы.ПС, Ложь);
		СтраховойПакет	= СтрСоединить(МассивСтрок, Символы.ПС);
		
		ОбластьШапка.Параметры.СтраховойПакет		= СтраховойПакет;
		ОбластьШапка.Параметры.ФИОВладельца			= Выборка.Страхователь;
		ОбластьШапка.Параметры.НомерСертификата		= Выборка.НомерСертификата;
		
		ТабличныйДокумент.Вывести(ОбластьШапка);
		
		НастройкиСтраховыхПрограмм = РегистрыСведений.НастройкиСтраховыхПрограмм.ПолучитьНастройкиСраховыхПрограмм(Выборка.СтраховойПродукт, Выборка.СуммаПремии);
		
		КоличествоУслуг = 0;
		ВысотаТаблицы 	= ТабличныйДокумент.ВысотаТаблицы;
		
		Для Каждого СтрокаНастройка Из НастройкиСтраховыхПрограмм Цикл
			
			Если СтрокаНастройка.ЗначениеНастройки <> "" Тогда
				
				Если КоличествоУслуг = 0 Тогда
					
					СуммаПоРискам = НайтиСтраховуюСуммуПоРискам(Выборка.СуммаПремии);
					
					ОбластьУслуга.Параметры.Описание = СтрШаблон("Страхование действует в отношении транспортного средства: Марка - %1, Модель - %2, VIN - %3, No кузова - %4, , гос. номер - %5 
						|Количество посадочных мест не более 5-ти.
						|Страховая сумма установлена «по паушальной системе»* – %6 руб.
						|Водители и пассажиры застрахованы по рискам: 
						|1.   «Смерть в результате несчастного случая», 
						|2.   «Инвалидность в результате несчастного случая», 
						|3.   «Телесные повреждения в результате несчастного случая».;", Выборка.Марка, Выборка.Модель, Выборка.VIN, Выборка.НомерКузова, Выборка.ГРН, СуммаПоРискам);	
					
					ТабличныйДокумент.Вывести(ОбластьУслуга);
						
					КоличествоУслуг = КоличествоУслуг + 1
					
				КонецЕсли;
				
				Если СтрокаНастройка.ВидНастройки = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.БесплатныйНомерДляОбращенияЗаУслугой Тогда
					ОбластьУслуги.Параметры.ОписаниеУслуги = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.БесплатныйНомерДляОбращенияЗаУслугой.Наименование;
				ИначеЕсли СтрокаНастройка.ВидНастройки = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.ПодборСтраховойКомпании Тогда
					ОбластьУслуги.Параметры.ОписаниеУслуги = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.ПодборСтраховойКомпании.Наименование;
				ИначеЕсли СтрокаНастройка.ВидНастройки = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.УстнаяКонсультация Тогда
					ОбластьУслуги.Параметры.ОписаниеУслуги = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.УстнаяКонсультация.Наименование;
				ИначеЕсли СтрокаНастройка.ВидНастройки = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.ПодготовкаДокументов Тогда
					ОбластьУслуги.Параметры.ОписаниеУслуги = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.ПодготовкаДокументов.Наименование;
				ИначеЕсли СтрокаНастройка.ВидНастройки = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.ПредоставлениеТиповыхФормДокументов Тогда
					ОбластьУслуги.Параметры.ОписаниеУслуги = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.ПредоставлениеТиповыхФормДокументов.Наименование;
				ИначеЕсли СтрокаНастройка.ВидНастройки = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.УстнаяКонсультацияПоУрегулированиюСтраховогоСлучая Тогда
					ОбластьУслуги.Параметры.ОписаниеУслуги = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.УстнаяКонсультацияПоУрегулированиюСтраховогоСлучая.Наименование;
				ИначеЕсли СтрокаНастройка.ВидНастройки = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.ПодборЭкспертныхКомпаний Тогда
					ОбластьУслуги.Параметры.ОписаниеУслуги = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.ПодборЭкспертныхКомпаний.Наименование;
				ИначеЕсли СтрокаНастройка.ВидНастройки = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.ПодготовкаДокументовДляУрегулированияСтраховогоСлучая Тогда
					ОбластьУслуги.Параметры.ОписаниеУслуги = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.ПодготовкаДокументовДляУрегулированияСтраховогоСлучая.Наименование; 
				ИначеЕсли СтрокаНастройка.ВидНастройки = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.ПредоставлениеТиповыхФормДокументовПоУрегулированиюСтраховогоСлучая Тогда
					ОбластьУслуги.Параметры.ОписаниеУслуги = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.ПредоставлениеТиповыхФормДокументовПоУрегулированиюСтраховогоСлучая.Наименование;
				ИначеЕсли СтрокаНастройка.ВидНастройки = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.УслугаПоПрисоединениюККоллективномуДоговору Тогда
					 ОбластьУслуги.Параметры.ОписаниеУслуги = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.УслугаПоПрисоединениюККоллективномуДоговору.Наименование;
				Иначе
					Продолжить;	
				КонецЕсли;
				
				ОбластьУслуги.Параметры.ОбъемУслуги = СтрокаНастройка.ЗначениеНастройки;
				
				ОбластьУслуги.Параметры.ТекстУслуги = "Консультационно - информационные услуги";
				
				ТабличныйДокумент.Вывести(ОбластьУслуги); 
				
				КоличествоУслуг = КоличествоУслуг + 1;
				
			КонецЕсли;
			
		КонецЦикла;
		
		ОбъединениеНачало = 13; 
		
		Для НомерСтроки = 13 По 13 + КоличествоУслуг Цикл  
			
			Если ТабличныйДокумент.Область(НомерСтроки, 2, НомерСтроки,2).Текст = ТабличныйДокумент.Область((НомерСтроки - 1), 2, (НомерСтроки - 1), 2).Текст Или ОбъединениеНачало = НомерСтроки Тогда
				Продолжить;
			Иначе
				ТабличныйДокумент.Область(ОбъединениеНачало, 2, НомерСтроки - 1, 2).Объединить();
				ОбъединениеНачало = НомерСтроки;
			КонецЕсли;   
			
		КонецЦикла;  
				
		ОбластьПодвал.Параметры.ДатаОформления	= Формат(Выборка.ДатаОформления, "ДЛФ=Д");
		ОбластьПодвал.Параметры.СтоимостьУслуг 	= Выборка.СуммаПремии;
		
		ТабличныйДокумент.Вывести(ОбластьПодвал);
		
	КонецЕсли;
	
	Возврат ТабличныйДокумент;
	
КонецФункции

Функция НайтиСтраховуюСуммуПоРискам(СуммаПремии, СтраховойПродукт = Неопределено, ВидНастройки = Неопределено)  
	
	Запрос = Новый Запрос;
	Запрос.Текст = 
	"ВЫБРАТЬ
	|	НастройкиСтраховыхПрограммСрезПоследних.ЗначениеНастройки КАК ЗначениеНастройки
	|ИЗ
	|	РегистрСведений.НастройкиСтраховыхПрограмм.СрезПоследних КАК НастройкиСтраховыхПрограммСрезПоследних
	|ГДЕ
	|	НастройкиСтраховыхПрограммСрезПоследних.СтраховойПродукт = &СтраховойПродукт
	|	И НастройкиСтраховыхПрограммСрезПоследних.СуммаПремии = &СуммаПремии
	|	И НастройкиСтраховыхПрограммСрезПоследних.ВидНастройки = &ВидНастройки";
	
	Если ЗначениеЗаполнено(ВидНастройки) Тогда
		Запрос.УстановитьПараметр("ВидНастройки", ВидНастройки);
	Иначе
		Запрос.УстановитьПараметр("ВидНастройки", ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.СтраховаяСуммаПоРискам);	
	КонецЕсли;
		
	Если ЗначениеЗаполнено(СтраховойПродукт) Тогда
		Запрос.УстановитьПараметр("СтраховойПродукт", СтраховойПродукт);
	Иначе
		Запрос.УстановитьПараметр("СтраховойПродукт", Справочники.СтраховыеПродукты.АвтопомощникПлюс);	
	КонецЕсли;

	Запрос.УстановитьПараметр("СуммаПремии", СуммаПремии);
	
	РезультатЗапроса = Запрос.Выполнить();
	
	ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
	
	Если ВыборкаДетальныеЗаписи.Следующий() Тогда  		
		Сумма = ВыборкаДетальныеЗаписи.ЗначениеНастройки;	
	КонецЕсли; 
	
	Возврат Сумма;
	
КонецФункции

Функция ОпределитьСтраховойПакет(СуммаПремии, СтраховойПродукт)  
	
	СтраховойПакет = "";
		
	Запрос = Новый Запрос;
	Запрос.Текст = 
	"ВЫБРАТЬ
	|	НастройкиСтраховыхПродуктовСрезПоследних.ПолноеОписание КАК ПолноеОписание
	|ИЗ
	|	РегистрСведений.НастройкиСтраховыхПродуктов.СрезПоследних КАК НастройкиСтраховыхПродуктовСрезПоследних
	|ГДЕ
	|	НастройкиСтраховыхПродуктовСрезПоследних.СтраховойПродукт = &СтраховойПродукт
	|	И НастройкиСтраховыхПродуктовСрезПоследних.СуммаПремии = &СуммаПремии";
	//|	И НастройкиСтраховыхПродуктовСрезПоследних.СтраховаяКомпания = &СтраховаяКомпания";
	
	//Запрос.УстановитьПараметр("СтраховаяКомпания", Справочники.ЭмитентыПродуктов.НайтиПоНаименованию("РСА (Российский Союз Автостраховщиков)"));
	Запрос.УстановитьПараметр("СтраховойПродукт", СтраховойПродукт);
	Запрос.УстановитьПараметр("СуммаПремии", СуммаПремии);
	
	РезультатЗапроса = Запрос.Выполнить();
	
	ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
	
	Если ВыборкаДетальныеЗаписи.Следующий() Тогда
		СтраховойПакет = ВыборкаДетальныеЗаписи.ПолноеОписание; 
	КонецЕсли;
		
	Возврат СтраховойПакет;
	
КонецФункции

Функция ПолучитьПредставлениеОбъемаУслуги(ЗначениеНастройки)
	
	ОбъемУслуги = "";
	
	Если ЗначениеНастройки = -1 Тогда
		ОбъемУслуги = "Безлимитно";
	ИначеЕсли ЗначениеНастройки <> 0 Тогда
		ОбъемУслуги = СтрШаблон("%1  в год", ЗначениеНастройки);
	КонецЕсли;
	
	Возврат ОбъемУслуги;
	
КонецФункции

Процедура Печать(ИдентификаторКоманды, ОбъектыНазначения, ПараметрыКоманды) Экспорт 
	
	Если ОбъектыНазначения.Количество() = 1 Тогда
		ОбъектНазначения = ОбъектыНазначения[0];	
	Иначе
		ЗаписьЖурналаРегистрации(НСтр("ru = 'Получение внешней печатной формы'", ОбщегоНазначения.КодОсновногоЯзыка()),
		УровеньЖурналаРегистрации.Ошибка,,, "Количество переданных объектов в функцию печати не равно 1");
		Возврат;
	КонецЕсли;
	
	Если ИдентификаторКоманды = "ПечатьДоговораСтрахованияДВС" Тогда
		
		Если ОбъектНазначения.СтраховойПродукт = Справочники.СтраховыеПродукты.СервисАвтопомощник Тогда
			ИдентификаторКоманды = "Автопомощник";
		ИначеЕсли ОбъектНазначения.СтраховойПродукт = Справочники.СтраховыеПродукты.ДокторВДорогу Тогда
			ИдентификаторКоманды = "ДокторВДорогу";
		ИначеЕсли ОбъектНазначения.СтраховойПродукт = Справочники.СтраховыеПродукты.СпросиУЮриста Тогда
			ИдентификаторКоманды = "СпросиУЮриста"; 
		ИначеЕсли ОбъектНазначения.СтраховойПродукт = Справочники.СтраховыеПродукты.АвтопомощникПлюс Тогда
			ИдентификаторКоманды = "АвтопомощникПлюс"; 
		ИначеЕсли ОбъектНазначения.СтраховойПродукт = Справочники.СтраховыеПродукты.ЗащитаПриДТППлюс Тогда
			ИдентификаторКоманды = "ЗащитаПриДТППлюс";
		ИначеЕсли ОбъектНазначения.СтраховойПродукт = Справочники.СтраховыеПродукты.ЗащитаПриДТП Тогда
			ИдентификаторКоманды = "ЗащитаПриДТП";
		ИначеЕсли ОбъектНазначения.СтраховойПродукт = Справочники.СтраховыеПродукты.Помощь Тогда
			ИдентификаторКоманды = "Помощь";	
		ИначеЕсли ОбъектНазначения.СтраховойПродукт = Справочники.СтраховыеПродукты.НадежнаяПоездка Тогда
			ИдентификаторКоманды = "НадежнаяПоездка";
		ИначеЕсли ОбъектНазначения.СтраховойПродукт = Справочники.СтраховыеПродукты.НадежнаяПоездкаПлюс Тогда
			ИдентификаторКоманды = "НадежнаяПоездкаПлюс";
		Иначе
			Возврат;
		КонецЕсли; 
		
	КонецЕсли; 
	
	Если ИдентификаторКоманды = "ДокторВДорогу" Тогда
		ТабДок 				= ПолучитьПечатнуюФорму_ДокторВДорогу_СпросиУЮриста(ОбъектНазначения);
		ИмяБезРасширения 	= "Доктор в дорогу";
	ИначеЕсли ИдентификаторКоманды = "СпросиУЮриста" Тогда
		ТабДок 				= ПолучитьПечатнуюФорму_ДокторВДорогу_СпросиУЮриста(ОбъектНазначения);
		ИмяБезРасширения 	= "Спроси у юриста";	
	ИначеЕсли ИдентификаторКоманды = "Автопомощник" Тогда
		ТабДок 				= ПолучитьПечатнуюФорму_Автопомощник(ОбъектНазначения);
		ИмяБезРасширения 	= "Автопомощник";
	ИначеЕсли ИдентификаторКоманды = "АвтопомощникПлюс" Тогда
		ТабДок 				= ПолучитьПечатнуюФорму_АвтопомощникПлюс(ОбъектНазначения);
		ИмяБезРасширения 	= "АвтопомощникПлюс";  
	ИначеЕсли ИдентификаторКоманды = "ЗащитаПриДТППлюс" Тогда
		ТабДок 				= ПолучитьПечатнуюФорму_ЗащитаПриДТППлюс(ОбъектНазначения);
		ИмяБезРасширения 	= "ЗащитаПриДТППлюс";	
	ИначеЕсли ИдентификаторКоманды = "ЗащитаПриДТП" Тогда
		ТабДок 				= ПолучитьПечатнуюФорму_ЗащитаПриДТП(ОбъектНазначения);
		ИмяБезРасширения 	= "ЗащитаПриДТП";
	ИначеЕсли ИдентификаторКоманды = "НадежнаяПоездка" Тогда
		ТабДок 				= ПолучитьПечатнуюФорму_НадежнаяПоездка(ОбъектНазначения);
		ИмяБезРасширения 	= "НадежнаяПоездка"; 
	ИначеЕсли ИдентификаторКоманды = "НадежнаяПоездкаПлюс" Тогда
		ТабДок 				= ПолучитьПечатнуюФорму_НадежнаяПоездкаПлюс(ОбъектНазначения);
		ИмяБезРасширения 	= "НадежнаяПоездкаПлюс"; 
	ИначеЕсли ИдентификаторКоманды = "Помощь" Тогда
		ТабДок 				= ПолучитьПечатнуюФорму_Помощь(ОбъектНазначения);
		ИмяБезРасширения 	= "Помощь";	
	Иначе
		Возврат;
	КонецЕсли;
	
	ПараметрыКоманды.РезультатВыполнения.Вставить("ПечатнаяФорма", ТабДок);
	ПараметрыКоманды.РезультатВыполнения.Вставить("ИмяБезРасширения", ИмяБезРасширения);
	
КонецПроцедуры

Функция ПолучитьПечатнуюФорму_ЗащитаПриДТППлюс(ОбъектНазначения) Экспорт 
	
	ТабличныйДокумент = Новый ТабличныйДокумент;
	
	Запрос = Новый Запрос;
	Запрос.Текст =
	"ВЫБРАТЬ
	|	НастройкиСтраховыхПродуктовСрезПоследних.СуммаПремии КАК СуммаПремии,
	|	НастройкиСтраховыхПродуктовСрезПоследних.СтраховойПродукт КАК СтраховойПродукт,
	|	НастройкиСтраховыхПродуктовСрезПоследних.КраткоеОписание КАК КраткоеОписание
	|ПОМЕСТИТЬ ВТ_НастройкиСтраховыхПродуктов
	|ИЗ
	|	РегистрСведений.НастройкиСтраховыхПродуктов.СрезПоследних КАК НастройкиСтраховыхПродуктовСрезПоследних
	|;
	|
	|////////////////////////////////////////////////////////////////////////////////
	|ВЫБРАТЬ
	|	ДоговорыСтрахованияДВС.СтраховойПродукт КАК СтраховойПродукт,
	|	ДоговорыСтрахованияДВС.Страхователь КАК Страхователь,
	|	СертификатыСтраховыхПрограмм.НомерСертификата КАК НомерСертификата,
	|	СертификатыСтраховыхПрограмм.КодАктивации КАК КодАктивации,
	|	ДоговорыСтрахованияДВС.ДатаНачала КАК ДатаНачала,
	|	ДоговорыСтрахованияДВС.СуммаПремии КАК СуммаПремии,
	|	ВТ_НастройкиСтраховыхПродуктов.КраткоеОписание КАК КраткоеОписание,
	|	ВЫБОР
	|		КОГДА ДоговорСтрахования.ТранспортноеСредство_Марка = """"
	|			ТОГДА ""Отсутствует""
	|		ИНАЧЕ ДоговорСтрахования.ТранспортноеСредство_Марка
	|	КОНЕЦ КАК Марка,
	|	ВЫБОР
	|		КОГДА ДоговорСтрахования.ТранспортноеСредство_Модель = """"
	|			ТОГДА ""Отсутствует""
	|		ИНАЧЕ ДоговорСтрахования.ТранспортноеСредство_Модель
	|	КОНЕЦ КАК Модель,
	|	ВЫБОР
	|		КОГДА ДоговорСтрахования.ТранспортноеСредство_VIN = """"
	|			ТОГДА ""Отсутствует""
	|		ИНАЧЕ ДоговорСтрахования.ТранспортноеСредство_VIN
	|	КОНЕЦ КАК VIN,
	|	ВЫБОР
	|		КОГДА ДоговорСтрахования.ТранспортноеСредство_НомерКузова = """"
	|			ТОГДА ""Отсутствует""
	|		ИНАЧЕ ДоговорСтрахования.ТранспортноеСредство_НомерКузова
	|	КОНЕЦ КАК НомерКузова,
	|	ВЫБОР
	|		КОГДА ДоговорСтрахования.ТранспортноеСредство_ГРН = """"
	|			ТОГДА ""Отсутствует""
	|		ИНАЧЕ ДоговорСтрахования.ТранспортноеСредство_ГРН
	|	КОНЕЦ КАК ГРН,
	|	ДоговорыСтрахованияДВС.Дата КАК ДатаОформления,
	|	ВТ_НастройкиСтраховыхПродуктов.КраткоеОписание КАК КраткоеОписание1
	|ИЗ
	|	Документ.ДоговорСтрахованияДВС КАК ДоговорыСтрахованияДВС
	|		ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрСведений.СертификатыСтраховыхПрограмм КАК СертификатыСтраховыхПрограмм
	|			ВНУТРЕННЕЕ СОЕДИНЕНИЕ ВТ_НастройкиСтраховыхПродуктов КАК ВТ_НастройкиСтраховыхПродуктов
	|			ПО СертификатыСтраховыхПрограмм.СтраховойПродукт = ВТ_НастройкиСтраховыхПродуктов.СтраховойПродукт
	|				И СертификатыСтраховыхПрограмм.СуммаПремии = ВТ_НастройкиСтраховыхПродуктов.СуммаПремии
	|		ПО ДоговорыСтрахованияДВС.Ссылка = СертификатыСтраховыхПрограмм.ДоговорСтрахованияДВС
	|		ЛЕВОЕ СОЕДИНЕНИЕ Документ.ДоговорСтрахованияОСАГО КАК ДоговорСтрахования
	|		ПО ДоговорыСтрахованияДВС.ДоговорСтрахованияОСАГО = ДоговорСтрахования.Ссылка
	|ГДЕ
	|	ДоговорыСтрахованияДВС.Ссылка = &Ссылка";
	
	Запрос.УстановитьПараметр("Ссылка", ОбъектНазначения);
	
	РезультатЗапроса = Запрос.Выполнить();
	Выборка = РезультатЗапроса.Выбрать();
	
	Если Выборка.Следующий() Тогда
		
		Макет = ПолучитьМакет("ЗащитаПриДТППлюс");
		
		ОбластьШапка 	= Макет.ПолучитьОбласть("Шапка");
		ОбластьУслуга 	= Макет.ПолучитьОбласть("Услуга");
		ОбластьУслуги 	= Макет.ПолучитьОбласть("Услуги");
		ОбластьПодвал 	= Макет.ПолучитьОбласть("Подвал");
		
		СтраховойПакет 	= ОпределитьСтраховойПакет(Выборка.СуммаПремии, Справочники.СтраховыеПродукты.ЗащитаПриДТППлюс);
		СтраховойПакет 	= СокрЛП(СтраховойПакет);
		МассивСтрок 	= СтрРазделить(СтраховойПакет, Символы.ПС, Ложь);
		СтраховойПакет	= СтрСоединить(МассивСтрок, Символы.ПС);
		
		ОбластьШапка.Параметры.СтраховойПакет		= СтраховойПакет;
		ОбластьШапка.Параметры.ФИОВладельца			= Выборка.Страхователь;
		ОбластьШапка.Параметры.НомерСертификата		= Выборка.НомерСертификата;
		
		ТабличныйДокумент.Вывести(ОбластьШапка);
		
		НастройкиСтраховыхПрограмм = РегистрыСведений.НастройкиСтраховыхПрограмм.ПолучитьНастройкиСраховыхПрограмм(Выборка.СтраховойПродукт, Выборка.СуммаПремии);
		
		КоличествоУслуг = 0;
		ВысотаТаблицы 	= ТабличныйДокумент.ВысотаТаблицы;
		
		Для Каждого СтрокаНастройка Из НастройкиСтраховыхПрограмм Цикл
			
			Если СтрокаНастройка.ЗначениеНастройки <> "" Тогда
				
				Если КоличествоУслуг = 0 Тогда
										
					СтрокаСуммаПоРискам = НастройкиСтраховыхПрограмм.Найти(ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.СтраховаяСуммаПоРискамЗащитаПриДТППлюс, "ВидНастройки");
					Если СтрокаСуммаПоРискам = Неопределено Тогда
						Возврат Неопределено;
					КонецЕсли;  
					
					СуммаПоРискам = СтрокаСуммаПоРискам.ЗначениеНастройки; 
				
					ОбластьУслуга.Параметры.Описание = СтрШаблон("Страхование действует в отношении транспортного средства: Марка - %1, Модель - %2, VIN - %3, No кузова - %4, , гос. номер - %5 
						|Количество посадочных мест не более 5-ти.
						|
						|Страховая сумма установлена «по паушальной системе»* – %6 руб.
						|
						|Водители и пассажиры застрахованы по рискам:
						|
						|1.   «Смерть в результате несчастного случая», 
						|2.   «Инвалидность в результате несчастного случая», 
						|3.   «Телесные повреждения в результате несчастного случая».
						|
						|
						|Срок страхования: по рискам «Смерть в результате несчастного случая», «Инвалидность в результате несчастного случая» и «Телесные повреждения в результате несчастного случая» - 12 месяцев с даты начала срока страхования с даты начала срока страхования."
						, Выборка.Марка, Выборка.Модель, Выборка.VIN, Выборка.НомерКузова, Выборка.ГРН, СуммаПоРискам);	
					
					ТабличныйДокумент.Вывести(ОбластьУслуга);
						
					КоличествоУслуг = КоличествоУслуг + 1
					
				КонецЕсли;
				
				Если СтрокаНастройка.ВидНастройки = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.БесплатныйНомерДляОбращенияЗаУслугойЗащитаПриДТППлюс Тогда
					ОбластьУслуги.Параметры.ОписаниеУслуги = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.БесплатныйНомерДляОбращенияЗаУслугойЗащитаПриДТППлюс;
				ИначеЕсли СтрокаНастройка.ВидНастройки = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.УстнаяКонсультацияЗащитаПриДТППлюс Тогда
					ОбластьУслуги.Параметры.ОписаниеУслуги = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.УстнаяКонсультацияЗащитаПриДТППлюс;
				ИначеЕсли СтрокаНастройка.ВидНастройки = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.ПредоставлениеТиповыхФормДокументовЗащитаПриДТППлюс Тогда
					ОбластьУслуги.Параметры.ОписаниеУслуги = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.ПредоставлениеТиповыхФормДокументовЗащитаПриДТППлюс;
				ИначеЕсли СтрокаНастройка.ВидНастройки = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.УстнаяКонсультацияПоУрегулированиюСтраховогоСлучаяЗащитаПриДТППлюс Тогда
					ОбластьУслуги.Параметры.ОписаниеУслуги = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.УстнаяКонсультацияПоУрегулированиюСтраховогоСлучаяЗащитаПриДТППлюс;
				ИначеЕсли СтрокаНастройка.ВидНастройки = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.ПредоставлениеТиповыхФормДокументовПоУрегулированиюСтраховогоСлучаяЗащитаПриДТППлюс Тогда
					ОбластьУслуги.Параметры.ОписаниеУслуги = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.ПредоставлениеТиповыхФормДокументовПоУрегулированиюСтраховогоСлучаяЗащитаПриДТППлюс;
				Иначе
					Продолжить;	
				КонецЕсли;
				
				ОбластьУслуги.Параметры.ОбъемУслуги = СтрокаНастройка.ЗначениеНастройки;
				ОбластьУслуги.Параметры.ТекстУслуги = "Услуги";
				
				ТабличныйДокумент.Вывести(ОбластьУслуги); 
				
				КоличествоУслуг = КоличествоУслуг + 1;
				
			КонецЕсли;
			
		КонецЦикла;
		
		ОбъединениеНачало = 13; 
		
		Для НомерСтроки = 13 По 13 + КоличествоУслуг Цикл  
			
			Если ТабличныйДокумент.Область(НомерСтроки, 2, НомерСтроки,2).Текст = ТабличныйДокумент.Область((НомерСтроки - 1), 2, (НомерСтроки - 1), 2).Текст Или ОбъединениеНачало = НомерСтроки Тогда
				Продолжить;
			Иначе
				ТабличныйДокумент.Область(ОбъединениеНачало, 2, НомерСтроки - 1, 2).Объединить();
				ОбъединениеНачало = НомерСтроки;
			КонецЕсли;   
			
		КонецЦикла;  
				
		ОбластьПодвал.Параметры.ДатаОформления	= Формат(Выборка.ДатаОформления, "ДЛФ=Д");
		ОбластьПодвал.Параметры.СтоимостьУслуг 	= Выборка.СуммаПремии;
		
		ТабличныйДокумент.Вывести(ОбластьПодвал);
		
	КонецЕсли;
	
	Возврат ТабличныйДокумент;
	
КонецФункции

Функция ПолучитьПечатнуюФорму_ЗащитаПриДТП(ОбъектНазначения) Экспорт 
	
	ТабличныйДокумент = Новый ТабличныйДокумент;
	
	Запрос = Новый Запрос;
	Запрос.Текст =
	"ВЫБРАТЬ
	|	НастройкиСтраховыхПродуктовСрезПоследних.СуммаПремии КАК СуммаПремии,
	|	НастройкиСтраховыхПродуктовСрезПоследних.СтраховойПродукт КАК СтраховойПродукт,
	|	НастройкиСтраховыхПродуктовСрезПоследних.КраткоеОписание КАК КраткоеОписание
	|ПОМЕСТИТЬ ВТ_НастройкиСтраховыхПродуктов
	|ИЗ
	|	РегистрСведений.НастройкиСтраховыхПродуктов.СрезПоследних КАК НастройкиСтраховыхПродуктовСрезПоследних
	|;
	|
	|////////////////////////////////////////////////////////////////////////////////
	|ВЫБРАТЬ
	|	ДоговорыСтрахованияДВС.СтраховойПродукт КАК СтраховойПродукт,
	|	ДоговорыСтрахованияДВС.Страхователь КАК Страхователь,
	|	СертификатыСтраховыхПрограмм.НомерСертификата КАК НомерСертификата,
	|	СертификатыСтраховыхПрограмм.КодАктивации КАК КодАктивации,
	|	ДоговорыСтрахованияДВС.ДатаНачала КАК ДатаНачала,
	|	ДоговорыСтрахованияДВС.СуммаПремии КАК СуммаПремии,
	|	ВТ_НастройкиСтраховыхПродуктов.КраткоеОписание КАК КраткоеОписание,
	|	ВЫБОР
	|		КОГДА ДоговорСтрахования.ТранспортноеСредство_Марка = """"
	|			ТОГДА ""Отсутствует""
	|		ИНАЧЕ ДоговорСтрахования.ТранспортноеСредство_Марка
	|	КОНЕЦ КАК Марка,
	|	ВЫБОР
	|		КОГДА ДоговорСтрахования.ТранспортноеСредство_Модель = """"
	|			ТОГДА ""Отсутствует""
	|		ИНАЧЕ ДоговорСтрахования.ТранспортноеСредство_Модель
	|	КОНЕЦ КАК Модель,
	|	ВЫБОР
	|		КОГДА ДоговорСтрахования.ТранспортноеСредство_VIN = """"
	|			ТОГДА ""Отсутствует""
	|		ИНАЧЕ ДоговорСтрахования.ТранспортноеСредство_VIN
	|	КОНЕЦ КАК VIN,
	|	ВЫБОР
	|		КОГДА ДоговорСтрахования.ТранспортноеСредство_НомерКузова = """"
	|			ТОГДА ""Отсутствует""
	|		ИНАЧЕ ДоговорСтрахования.ТранспортноеСредство_НомерКузова
	|	КОНЕЦ КАК НомерКузова,
	|	ВЫБОР
	|		КОГДА ДоговорСтрахования.ТранспортноеСредство_ГРН = """"
	|			ТОГДА ""Отсутствует""
	|		ИНАЧЕ ДоговорСтрахования.ТранспортноеСредство_ГРН
	|	КОНЕЦ КАК ГРН,
	|	ДоговорыСтрахованияДВС.Дата КАК ДатаОформления,
	|	ВТ_НастройкиСтраховыхПродуктов.КраткоеОписание КАК КраткоеОписание1
	|ИЗ
	|	Документ.ДоговорСтрахованияДВС КАК ДоговорыСтрахованияДВС
	|		ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрСведений.СертификатыСтраховыхПрограмм КАК СертификатыСтраховыхПрограмм
	|			ВНУТРЕННЕЕ СОЕДИНЕНИЕ ВТ_НастройкиСтраховыхПродуктов КАК ВТ_НастройкиСтраховыхПродуктов
	|			ПО СертификатыСтраховыхПрограмм.СтраховойПродукт = ВТ_НастройкиСтраховыхПродуктов.СтраховойПродукт
	|				И СертификатыСтраховыхПрограмм.СуммаПремии = ВТ_НастройкиСтраховыхПродуктов.СуммаПремии
	|		ПО ДоговорыСтрахованияДВС.Ссылка = СертификатыСтраховыхПрограмм.ДоговорСтрахованияДВС
	|		ЛЕВОЕ СОЕДИНЕНИЕ Документ.ДоговорСтрахованияОСАГО КАК ДоговорСтрахования
	|		ПО ДоговорыСтрахованияДВС.ДоговорСтрахованияОСАГО = ДоговорСтрахования.Ссылка
	|ГДЕ
	|	ДоговорыСтрахованияДВС.Ссылка = &Ссылка";
	
	Запрос.УстановитьПараметр("Ссылка", ОбъектНазначения);
	
	РезультатЗапроса = Запрос.Выполнить();
	Выборка = РезультатЗапроса.Выбрать();
	
	Если Выборка.Следующий() Тогда
		
		Макет = ПолучитьМакет("ЗащитаПриДТП");
		
		ОбластьШапка 	= Макет.ПолучитьОбласть("Шапка");
		ОбластьУслуга 	= Макет.ПолучитьОбласть("Услуга");
		ОбластьУслуги 	= Макет.ПолучитьОбласть("Услуги");
		ОбластьПодвал 	= Макет.ПолучитьОбласть("Подвал");
		
		СтраховойПакет 	= ОпределитьСтраховойПакет(Выборка.СуммаПремии, Справочники.СтраховыеПродукты.ЗащитаПриДТП);
		СтраховойПакет 	= СокрЛП(СтраховойПакет);
		МассивСтрок 	= СтрРазделить(СтраховойПакет, Символы.ПС, Ложь);
		СтраховойПакет	= СтрСоединить(МассивСтрок, Символы.ПС);
		
		ОбластьШапка.Параметры.СтраховойПакет		= СтраховойПакет;
		ОбластьШапка.Параметры.ФИОВладельца			= Выборка.Страхователь;
		ОбластьШапка.Параметры.НомерСертификата		= Выборка.НомерСертификата;
		
		ТабличныйДокумент.Вывести(ОбластьШапка);
		
		НастройкиСтраховыхПрограмм = РегистрыСведений.НастройкиСтраховыхПрограмм.ПолучитьНастройкиСраховыхПрограмм(Выборка.СтраховойПродукт, Выборка.СуммаПремии);
		
		КоличествоУслуг = 0;
		ВысотаТаблицы 	= ТабличныйДокумент.ВысотаТаблицы;
		
		Для Каждого СтрокаНастройка Из НастройкиСтраховыхПрограмм Цикл
			
			Если СтрокаНастройка.ЗначениеНастройки <> "" Тогда
				
				Если КоличествоУслуг = 0 Тогда
										
					СтрокаСуммаПоРискам = НастройкиСтраховыхПрограмм.Найти(ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.СтраховаяСуммаПоРискамЗащитаПриДТППлюс, "ВидНастройки");
					Если СтрокаСуммаПоРискам = Неопределено Тогда
						Возврат Неопределено;
					КонецЕсли;  
					
					СуммаПоРискам = СтрокаСуммаПоРискам.ЗначениеНастройки; 
					
					ОбластьУслуга.Параметры.Описание = СтрШаблон("Страхование действует в отношении транспортного средства: Марка - %1, Модель - %2, VIN - %3, No кузова - %4, , гос. номер - %5 
						|Количество посадочных мест не более 5-ти.
						|
						|Страховая сумма установлена «по паушальной системе»* – %6 руб.
						|
						|Водители и пассажиры застрахованы по рискам:
						|
						|1.   «Смерть в результате несчастного случая», 
						|2.   «Инвалидность в результате несчастного случая», 
						|3.   «Телесные повреждения в результате несчастного случая».
						|
						|
						|Срок страхования: по рискам «Смерть в результате несчастного случая» и «Инвалидность в результате несчастного случая» - 12 месяцев с даты начала срока страхования. По риску «Телесные повреждения в результате несчастного случая» - 1 месяц с даты начала срока страхования"
						, Выборка.Марка, Выборка.Модель, Выборка.VIN, Выборка.НомерКузова, Выборка.ГРН, СуммаПоРискам);	
					
					ТабличныйДокумент.Вывести(ОбластьУслуга);
						
					КоличествоУслуг = КоличествоУслуг + 1
					
				КонецЕсли;
				
				Если СтрокаНастройка.ВидНастройки = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.БесплатныйНомерДляОбращенияЗаУслугойЗащитаПриДТППлюс Тогда
					ОбластьУслуги.Параметры.ОписаниеУслуги = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.БесплатныйНомерДляОбращенияЗаУслугойЗащитаПриДТППлюс;
				ИначеЕсли СтрокаНастройка.ВидНастройки = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.УстнаяКонсультацияЗащитаПриДТППлюс Тогда
					ОбластьУслуги.Параметры.ОписаниеУслуги = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.УстнаяКонсультацияЗащитаПриДТППлюс;
				ИначеЕсли СтрокаНастройка.ВидНастройки = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.ПредоставлениеТиповыхФормДокументовЗащитаПриДТППлюс Тогда
					ОбластьУслуги.Параметры.ОписаниеУслуги = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.ПредоставлениеТиповыхФормДокументовЗащитаПриДТППлюс;
				ИначеЕсли СтрокаНастройка.ВидНастройки = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.УстнаяКонсультацияПоУрегулированиюСтраховогоСлучаяЗащитаПриДТППлюс Тогда
					ОбластьУслуги.Параметры.ОписаниеУслуги = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.УстнаяКонсультацияПоУрегулированиюСтраховогоСлучаяЗащитаПриДТППлюс;
				ИначеЕсли СтрокаНастройка.ВидНастройки = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.ПредоставлениеТиповыхФормДокументовПоУрегулированиюСтраховогоСлучаяЗащитаПриДТППлюс Тогда
					ОбластьУслуги.Параметры.ОписаниеУслуги = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.ПредоставлениеТиповыхФормДокументовПоУрегулированиюСтраховогоСлучаяЗащитаПриДТППлюс;
				Иначе
					Продолжить;	
				КонецЕсли;
				
				ОбластьУслуги.Параметры.ОбъемУслуги = СтрокаНастройка.ЗначениеНастройки;
				
				ОбластьУслуги.Параметры.ТекстУслуги = "Услуги";
				
				ТабличныйДокумент.Вывести(ОбластьУслуги); 
				
				КоличествоУслуг = КоличествоУслуг + 1;
				
			КонецЕсли;
			
		КонецЦикла;
		
		ОбъединениеНачало = 13; 
		
		Для НомерСтроки = 13 По 13 + КоличествоУслуг Цикл  
			
			Если ТабличныйДокумент.Область(НомерСтроки, 2, НомерСтроки,2).Текст = ТабличныйДокумент.Область((НомерСтроки - 1), 2, (НомерСтроки - 1), 2).Текст Или ОбъединениеНачало = НомерСтроки Тогда
				Продолжить;
			Иначе
				ТабличныйДокумент.Область(ОбъединениеНачало, 2, НомерСтроки - 1, 2).Объединить();
				ОбъединениеНачало = НомерСтроки;
			КонецЕсли;   
			
		КонецЦикла;  
				
		ОбластьПодвал.Параметры.ДатаОформления	= Формат(Выборка.ДатаОформления, "ДЛФ=Д");
		ОбластьПодвал.Параметры.СтоимостьУслуг 	= Выборка.СуммаПремии;
		
		ТабличныйДокумент.Вывести(ОбластьПодвал);
		
	КонецЕсли;
	
	Возврат ТабличныйДокумент;
	
КонецФункции

Функция ПолучитьПечатнуюФорму_Помощь(ОбъектНазначения) Экспорт
	
	СтраховойПродукт = Справочники.СтраховыеПродукты.Помощь;
	
	ТабличныйДокумент = Новый ТабличныйДокумент; 
	ТабличныйДокумент.АвтоМасштаб = Истина;
	
	// Хрусталев Андрей / 23.11.2023 13:51:47 / DEV-717 / начало
	ТабличныйДокумент.ВысотаСтраницы = 297;
	ТабличныйДокумент.ШиринаСтраницы = 210;
	
	ТабличныйДокумент.ПолеСлева 	 = 20;
	ТабличныйДокумент.ПолеСправа 	 = 10;
	ТабличныйДокумент.ПолеСверху 	 = 17.5;
	ТабличныйДокумент.ПолеСнизу 	 = 17.5;
	
	ТабличныйДокумент.ВерхнийКолонтитул.Выводить 		  = Истина;
	ТабличныйДокумент.ВерхнийКолонтитул.ТекстВЦентре 	  = "[&НомерСтраницы]";
	ТабличныйДокумент.ВерхнийКолонтитул.НачальнаяСтраница = 2;
	ТабличныйДокумент.РазмерКолонтитулаСверху 			  = 10;
	// Хрусталев Андрей / 23.11.2023 13:51:47 / DEV-717 / конец
	
	Запрос = Новый Запрос;
	Запрос.Текст =
	"ВЫБРАТЬ
	|	НастройкиСтраховыхПродуктовСрезПоследних.СуммаПремии КАК СуммаПремии,
	|	НастройкиСтраховыхПродуктовСрезПоследних.СтраховойПродукт КАК СтраховойПродукт,
	|	НастройкиСтраховыхПродуктовСрезПоследних.КраткоеОписание КАК КраткоеОписание
	|ПОМЕСТИТЬ ВТ_НастройкиСтраховыхПродуктов
	|ИЗ
	|	РегистрСведений.НастройкиСтраховыхПродуктов.СрезПоследних КАК НастройкиСтраховыхПродуктовСрезПоследних
	|;
	|
	|////////////////////////////////////////////////////////////////////////////////
	|ВЫБРАТЬ
	|	ДоговорыСтрахованияДВС.СтраховойПродукт КАК СтраховойПродукт,
	|	СертификатыСтраховыхПрограмм.НомерСертификата КАК НомерСертификата,
	|	СертификатыСтраховыхПрограмм.КодАктивации КАК КодАктивации,
	|	ДоговорыСтрахованияДВС.СуммаПремии КАК СуммаПремии,
	|	ВТ_НастройкиСтраховыхПродуктов.КраткоеОписание КАК КраткоеОписание,
	|	ДоговорыСтрахованияДВС.ДоговорСтрахованияОСАГО КАК ДоговорСтрахованияОСАГО,
	|	ДоговорыСтрахованияДВС.Дата КАК ДатаЗаключения
	|ИЗ
	|	Документ.ДоговорСтрахованияДВС КАК ДоговорыСтрахованияДВС
	|		ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрСведений.СертификатыСтраховыхПрограмм КАК СертификатыСтраховыхПрограмм
	|			ВНУТРЕННЕЕ СОЕДИНЕНИЕ ВТ_НастройкиСтраховыхПродуктов КАК ВТ_НастройкиСтраховыхПродуктов
	|			ПО СертификатыСтраховыхПрограмм.СтраховойПродукт = ВТ_НастройкиСтраховыхПродуктов.СтраховойПродукт
	|				И СертификатыСтраховыхПрограмм.СуммаПремии = ВТ_НастройкиСтраховыхПродуктов.СуммаПремии
	|		ПО ДоговорыСтрахованияДВС.Ссылка = СертификатыСтраховыхПрограмм.ДоговорСтрахованияДВС
	|ГДЕ
	|	ДоговорыСтрахованияДВС.Ссылка = &Ссылка";
	
	Запрос.УстановитьПараметр("Ссылка", ОбъектНазначения);
	
	СТС = Справочники.КлассификаторДокументов.СвидетельствоОРегистрацииТранспортногоСредства;
	
	РезультатЗапроса = Запрос.Выполнить();
	Выборка = РезультатЗапроса.Выбрать();
	
	Если Выборка.Следующий() Тогда
		
		СтруктураДоговора = Документы.ДоговорСтрахованияОСАГО.ПолучитьЗаполненнуюСтруктуруДоговораСтрахования(Выборка.ДоговорСтрахованияОСАГО);

		Макет = ПолучитьМакет("Помощь");
		
		ОбластьКИД			= Макет.ПолучитьОбласть("КИД");
		ОбластьШапка 		= Макет.ПолучитьОбласть("Шапка");
		ОбластьПодвал 		= Макет.ПолучитьОбласть("Подвал");

		ТабличныйДокумент.Вывести(ОбластьКИД); 
		
		ТабличныйДокумент.ВывестиГоризонтальныйРазделительСтраниц();
		
		ОбластьШапка.Параметры.СерияНомерПолиса = Выборка.НомерСертификата;
		ОбластьШапка.Параметры.ДатаЗаключения 	= Формат(Выборка.ДатаЗаключения, "ДЛФ=DD");
		
		// Страхователь		
		СтрокаСтрахователь = СтруктураДоговора.УчастникиДоговора.НайтиСтроки(Новый Структура("Роль", Справочники.РолиКонтрагентов.Страхователь)).Получить(0);
		СтрокаСтраховательАдрес = СтруктураДоговора.УчастникиДоговора_КИ.НайтиСтроки(Новый Структура("Роль, Вид", Справочники.РолиКонтрагентов.Страхователь, Справочники.ВидыКонтактнойИнформации.АдресРегистрации)).Получить(0);
		
		ОбластьШапка.Параметры.СрокСтрахования 				= СтрШаблон("с 00 ч. 00 мин. %1 г. по 23 ч.59 мин. %2 г.", Формат(СтруктураДоговора.Реквизиты.ДатаНачала, "ДФ=dd.MM.yyyy"), Формат(СтруктураДоговора.Реквизиты.ДатаОкончания, "ДФ=dd.MM.yyyy"));
				
		ОбластьШапка.Параметры.Страхователь 				= СтрокаСтрахователь.Наименование;
		ОбластьШапка.Параметры.Страхователь_Адрес 			= СтрокаСтраховательАдрес.Представление;
		ОбластьШапка.Параметры.ВидДокумента 				= СтрокаСтрахователь.Документы_ВидДокумента;
		ОбластьШапка.Параметры.Серия 						= СтрокаСтрахователь.Документы_Серия;
		ОбластьШапка.Параметры.Номер 						= СтрокаСтрахователь.Документы_Номер;
		ОбластьШапка.Параметры.ДатаВыдачи 					= Формат(СтрокаСтрахователь.Документы_ДатаВыдачи, "ДФ=dd.MM.yyyy");
		ОбластьШапка.Параметры.КемВыдан 					= "МВД России";
		ОбластьШапка.Параметры.ДатаРождения 				= Формат(СтрокаСтрахователь.ДатаРождения, "ДФ=dd.MM.yyyy");
		ОбластьШапка.Параметры.НомерТелефона 				= СтрокаСтраховательАдрес.НомерТелефона;
		ОбластьШапка.Параметры.АдресЭП 						= СтрокаСтраховательАдрес.АдресЭП;
		ОбластьШапка.Параметры.Выгодоприобретатель 			= СтрокаСтрахователь.Наименование;
		ОбластьШапка.Параметры.Выгодоприобретатель_Адрес 	= СтрокаСтраховательАдрес.Представление;
		
		// ТранспортноеСредство		
		ОбластьШапка.Параметры.ТранспортноеСредство 		= СтрШаблон("%1 %2", СтруктураДоговора.Реквизиты.Марка, СтруктураДоговора.Реквизиты.Модель);
		ОбластьШапка.Параметры.ГодВыпуска 					= СтруктураДоговора.Реквизиты.ГодВыпуска;
		ОбластьШапка.Параметры.Пробег 						= "";
		ОбластьШапка.Параметры.ГРН 							= СтруктураДоговора.Реквизиты.ГРН;
		ОбластьШапка.Параметры.СТС 							= ?(СтруктураДоговора.Реквизиты.Документ_ВидДокумента = СТС, СтруктураДоговора.Реквизиты.Документ_СерияНомер, "");
		ОбластьШапка.Параметры.ПТС 							= ?(СтруктураДоговора.Реквизиты.Документ_ВидДокумента <> СТС, СтруктураДоговора.Реквизиты.Документ_СерияНомер, "");
		ОбластьШапка.Параметры.ОбъемДвигателя 				= "";
		
		ИдентификаторТС 		= ОбменСоСтраховымиКомпаниями.ПолучитьПриоритетныйИдентификаторТС(СтруктураДоговора.Реквизиты.VIN, СтруктураДоговора.Реквизиты.НомерКузова, СтруктураДоговора.Реквизиты.НомерШасси);
		ДлинаИдентификатораТС 	= Мин(СтрДлина(ИдентификаторТС), 17);
		
		Для А = 1 По ДлинаИдентификатораТС Цикл
			ОбластьШапка.Параметры[СтрШаблон("VIN_%1", А)]  = Сред(ИдентификаторТС, А-1, 1);
		КонецЦикла;
		
		ТабличныйДокумент.Вывести(ОбластьШапка);
		
		// Водители		
		СтрокиВодителей = СтруктураДоговора.УчастникиДоговора.НайтиСтроки(Новый Структура("Роль", Справочники.РолиКонтрагентов.Водитель));
				
		ОбластьПодвал.Параметры.СтраховаяСумма 		= 400000;
		ОбластьПодвал.Параметры.Тариф 				= 0.4975;
		ОбластьПодвал.Параметры.СтраховаяПремия 	= Выборка.СуммаПремии;
		ОбластьПодвал.Параметры.СуммаПремииПрописью	= СтрШаблон("%1 руб. (%2)", Выборка.СуммаПремии, ЧислоПрописью(Выборка.СуммаПремии, "Л=ru_RU;ДП=Истина", "рубль, рубля, рублей, м, копейка, копейки, копеек, ж, 2"));
		ОбластьПодвал.Параметры.СрокОплатыСтрокой 	= СтрШаблон("Не позднее 23:59:59 %1", Формат(Выборка.ДатаЗаключения, "ДФ=dd.MM.yyyy"));
		ОбластьПодвал.Параметры.СрокОплаты 			= Формат(Выборка.ДатаЗаключения, "ДФ=dd.MM.yyyy");
		ОбластьПодвал.Параметры.СуммаОплаты 		= Выборка.СуммаПремии;		
		
		ТабличныйДокумент.Вывести(ОбластьПодвал);
		
	КонецЕсли;
	
	Возврат ТабличныйДокумент;
	
КонецФункции

Функция ПолучитьПечатнуюФорму_НадежнаяПоездка(ОбъектНазначения) Экспорт
	
	СтраховойПродукт = Справочники.СтраховыеПродукты.НадежнаяПоездка;
	
	ТабличныйДокумент = Новый ТабличныйДокумент; 
	
	ТабличныйДокумент.АвтоМасштаб = Истина;
	
	// Хрусталев Андрей / 23.11.2023 13:51:47 / DEV-717 / начало
	ТабличныйДокумент.ВысотаСтраницы = 297;
	ТабличныйДокумент.ШиринаСтраницы = 210;
	
	ТабличныйДокумент.ПолеСлева 	 = 20;
	ТабличныйДокумент.ПолеСправа 	 = 10;
	ТабличныйДокумент.ПолеСверху 	 = 17.5;
	ТабличныйДокумент.ПолеСнизу 	 = 17.5;
	
	ТабличныйДокумент.ВерхнийКолонтитул.Выводить 		  = Истина;
	ТабличныйДокумент.ВерхнийКолонтитул.ТекстВЦентре 	  = "[&НомерСтраницы]";
	ТабличныйДокумент.ВерхнийКолонтитул.НачальнаяСтраница = 2;
	ТабличныйДокумент.РазмерКолонтитулаСверху 			  = 10;
	// Хрусталев Андрей / 23.11.2023 13:51:47 / DEV-717 / конец

	Запрос = Новый Запрос;
	Запрос.Текст =
	"ВЫБРАТЬ
	|	НастройкиСтраховыхПродуктовСрезПоследних.СуммаПремии КАК СуммаПремии,
	|	НастройкиСтраховыхПродуктовСрезПоследних.СтраховойПродукт КАК СтраховойПродукт,
	|	НастройкиСтраховыхПродуктовСрезПоследних.КраткоеОписание КАК КраткоеОписание
	|ПОМЕСТИТЬ ВТ_НастройкиСтраховыхПродуктов
	|ИЗ
	|	РегистрСведений.НастройкиСтраховыхПродуктов.СрезПоследних КАК НастройкиСтраховыхПродуктовСрезПоследних
	|;
	|
	|////////////////////////////////////////////////////////////////////////////////
	|ВЫБРАТЬ
	|	ДоговорыСтрахованияДВС.СтраховойПродукт КАК СтраховойПродукт,
	|	СертификатыСтраховыхПрограмм.НомерСертификата КАК НомерСертификата,
	|	СертификатыСтраховыхПрограмм.КодАктивации КАК КодАктивации,
	|	ДоговорыСтрахованияДВС.СуммаПремии КАК СуммаПремии,
	|	ВТ_НастройкиСтраховыхПродуктов.КраткоеОписание КАК КраткоеОписание,
	|	ДоговорыСтрахованияДВС.ДоговорСтрахованияОСАГО КАК ДоговорСтрахованияОСАГО,
	|	ДоговорыСтрахованияДВС.Дата КАК Дата,
	|	ДоговорыСтрахованияДВС.ДатаНачала КАК ДатаНачалаРискИнойУчаствник,
	|	ДоговорыСтрахованияДВС.ДатаОкончания КАК ДатаОкончанияРискИнойУчаствник,
	|	ДоговорыСтрахованияДВС.ДатаНачала КАК ДатаНачалаРискНесчастныйСлучай,
	|	ДоговорыСтрахованияДВС.ДатаОкончания КАК ДатаОкончанияРискНесчастныйСлучай,
	|	ДоговорыСтрахованияДВС.Страхователь.ЮрФизЛицо КАК ЮрФизЛицо,
	|	ДоговорыСтрахованияДВС.Страхователь.Фамилия + "" "" + ДоговорыСтрахованияДВС.Страхователь.Имя + "" "" + ДоговорыСтрахованияДВС.Страхователь.Отчество КАК ФИО,
	|	ДоговорыСтрахованияДВС.Страхователь.ДатаРождения КАК ДатаРождения,
	|	КонтрагентыДокументы.ДатаВыдачи КАК ДатаВыдачи,
	|	КонтрагентыДокументы.Серия + "" "" + КонтрагентыДокументы.Номер КАК Паспорт,
	|	ДоговорыСтрахованияДВС.Страхователь.НомерТелефона КАК НомерТелефона,
	|	ДоговорыСтрахованияДВС.Страхователь.Наименование КАК Наименование,
	|	КонтрагентыКонтактнаяИнформация.Представление КАК Адрес,
	|	ДоговорыСтрахованияДВС.Страхователь.ОГРН КАК ОГРН,
	|	ДоговорыСтрахованияДВС.Страхователь.ИНН КАК ИНН,
	|	ДоговорыСтрахованияДВС.Страхователь.ГенеральныйДиректор КАК ГенеральныйДиректор,
	|	ДоговорОСАГО.ТранспортноеСредство_Марка.Наименование + "" "" + ДоговорОСАГО.ТранспортноеСредство_Модель.Наименование КАК МаркаМодель,
	|	ДоговорОСАГО.ТранспортноеСредство_ГодВыпуска КАК ГодВыпуска,
	|	ВЫБОР
	|		КОГДА ДоговорОСАГО.ТранспортноеСредство_VIN <> """"
	|			ТОГДА ДоговорОСАГО.ТранспортноеСредство_VIN
	|		КОГДА ДоговорОСАГО.ТранспортноеСредство_НомерКузова <> """"
	|			ТОГДА ДоговорОСАГО.ТранспортноеСредство_НомерКузова
	|		КОГДА ДоговорОСАГО.ТранспортноеСредство_НомерШасси <> """"
	|			ТОГДА ДоговорОСАГО.ТранспортноеСредство_НомерШасси
	|		ИНАЧЕ """"
	|	КОНЕЦ КАК VIN,
	|	ДоговорОСАГО.ТранспортноеСредство_ГРН КАК ГРН,
	|	ТранспортныеСредстваСТС.СерияНомер КАК СТС,
	|	ТранспортныеСредстваПТС.СерияНомер КАК ПТС,
	|	ДоговорыСтрахованияДВС.ДатаНачала КАК ДатаНачала
	|ИЗ
	|	Документ.ДоговорСтрахованияДВС КАК ДоговорыСтрахованияДВС
	|		ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрСведений.СертификатыСтраховыхПрограмм КАК СертификатыСтраховыхПрограмм
	|			ВНУТРЕННЕЕ СОЕДИНЕНИЕ ВТ_НастройкиСтраховыхПродуктов КАК ВТ_НастройкиСтраховыхПродуктов
	|			ПО СертификатыСтраховыхПрограмм.СтраховойПродукт = ВТ_НастройкиСтраховыхПродуктов.СтраховойПродукт
	|				И СертификатыСтраховыхПрограмм.СуммаПремии = ВТ_НастройкиСтраховыхПродуктов.СуммаПремии
	|		ПО ДоговорыСтрахованияДВС.Ссылка = СертификатыСтраховыхПрограмм.ДоговорСтрахованияДВС
	|		ЛЕВОЕ СОЕДИНЕНИЕ Справочник.Контрагенты.Документы КАК КонтрагентыДокументы
	|		ПО ДоговорыСтрахованияДВС.Страхователь = КонтрагентыДокументы.Ссылка
	|			И (КонтрагентыДокументы.ВидДокумента = ЗНАЧЕНИЕ(Справочник.КлассификаторДокументов.ПаспортРФ))
	|		ЛЕВОЕ СОЕДИНЕНИЕ Справочник.Контрагенты.КонтактнаяИнформация КАК КонтрагентыКонтактнаяИнформация
	|		ПО ДоговорыСтрахованияДВС.Страхователь = КонтрагентыКонтактнаяИнформация.Ссылка
	|			И (КонтрагентыКонтактнаяИнформация.Тип = ЗНАЧЕНИЕ(Перечисление.ТипыКонтактнойИнформации.Адрес))
	|			И (КонтрагентыКонтактнаяИнформация.Вид = ЗНАЧЕНИЕ(Справочник.ВидыКонтактнойИнформации.АдресОфиса))
	|		ВНУТРЕННЕЕ СОЕДИНЕНИЕ Документ.ДоговорСтрахованияОСАГО КАК ДоговорОСАГО
	|			ЛЕВОЕ СОЕДИНЕНИЕ Справочник.ТранспортныеСредства.Документы КАК ТранспортныеСредстваСТС
	|			ПО ДоговорОСАГО.ТранспортноеСредство = ТранспортныеСредстваСТС.Ссылка
	|				И (ТранспортныеСредстваСТС.ВидДокумента = ЗНАЧЕНИЕ(Справочник.КлассификаторДокументов.СвидетельствоОРегистрацииТранспортногоСредства))
	|			ЛЕВОЕ СОЕДИНЕНИЕ Справочник.ТранспортныеСредства.Документы КАК ТранспортныеСредстваПТС
	|			ПО ДоговорОСАГО.ТранспортноеСредство = ТранспортныеСредстваПТС.Ссылка
	|				И (ТранспортныеСредстваПТС.ВидДокумента = ЗНАЧЕНИЕ(Справочник.КлассификаторДокументов.ПаспортТранспортногоСредства))
	|		ПО ДоговорыСтрахованияДВС.ДоговорСтрахованияОСАГО = ДоговорОСАГО.Ссылка
	|ГДЕ
	|	ДоговорыСтрахованияДВС.Ссылка = &Ссылка";
	
	Запрос.УстановитьПараметр("Ссылка", ОбъектНазначения);
	
	РезультатЗапроса = Запрос.Выполнить();
	Выборка = РезультатЗапроса.Выбрать();
	
	Если Выборка.Следующий() Тогда
		
		Макет 			= ПолучитьМакет("НадежнаяПоездка");		
		ОбластьКИД 		= Макет.ПолучитьОбласть("КИД");
		
		ТабличныйДокумент.Вывести(ОбластьКИД); 
		
		ТабличныйДокумент.ВывестиГоризонтальныйРазделительСтраниц();
		
		ОбластьШапка 	= Макет.ПолучитьОбласть("Шапка");
		ОбластьУсловия 	= Макет.ПолучитьОбласть("УсловияСтрахования");
		
		ОбластьШапка.Параметры.СерияНомерПолиса						= Выборка.НомерСертификата;
		ОбластьШапка.Параметры.ДатаПолиса							= Формат(Выборка.Дата, "ДФ=dd.MM.yyyy");
		ОбластьШапка.Параметры.ДатаНачалаРискИнойУчаствник			= Формат(Выборка.ДатаНачалаРискИнойУчаствник, "ДФ=dd.MM.yyyy");
		ОбластьШапка.Параметры.ДатаОкончанияРискИнойУчаствник		= Формат(Выборка.ДатаОкончанияРискИнойУчаствник, "ДФ=dd.MM.yyyy");
		ОбластьШапка.Параметры.ДатаНачалаРискНесчастныйСлучай		= Формат(Выборка.ДатаНачалаРискНесчастныйСлучай, "ДФ=dd.MM.yyyy");
		ОбластьШапка.Параметры.ДатаОкончанияРискНесчастныйСлучай	= Формат(ДобавитьМесяц(Выборка.ДатаНачалаРискНесчастныйСлучай, 6) - 1, "ДФ=dd.MM.yyyy"); 
		
		ДанныеСтрахователя = ?(Выборка.ЮрФизЛицо = Перечисления.ЮрФизЛицо.ФизЛицо, 
								СтрШаблон("ФЛ: %1, дата рождения: %2, паспорт: %3, телефон: %4", Выборка.ФИО, Формат(Выборка.ДатаРождения, "ДФ=dd.MM.yyyy"), Выборка.Паспорт, Выборка.НомерТелефона),
								СтрШаблон("ЮЛ: %1, адрес: %2, ИНН: %3, ОГРН: %4, ФИО руководителя: %5", Выборка.Наименование, Выборка.Адрес, Выборка.ИНН, Выборка.ОГРН, Выборка.ГенеральныйДиректор));  
								
		ОбластьШапка.Параметры.ДанныеСтрахователя 			= ДанныеСтрахователя;	
		ОбластьШапка.Параметры.МаркаМодель 					= Выборка.МаркаМодель;
		ОбластьШапка.Параметры.ГодВыпуска           		= Выборка.ГодВыпуска;
		ОбластьШапка.Параметры.ВинШасси           			= Выборка.VIN;
		ОбластьШапка.Параметры.СвидетельствоОРегистрации    = Выборка.СТС;
		ОбластьШапка.Параметры.ПТС    						= Выборка.ПТС; 
		ОбластьШапка.Параметры.РегЗнак						= Выборка.ГРН;
			
		ТабличныйДокумент.Вывести(ОбластьШапка); 
		
		ОбластьУсловия.Параметры.СуммаДТПСИнымУчастником	= Формат(400000, "ЧДЦ=2");
		ОбластьУсловия.Параметры.ТарифДТПСИнымУчастником	= 0.123;
		ОбластьУсловия.Параметры.ПремияДТПСИнымУчастником	= Формат(490, "ЧДЦ=2"); 
		ОбластьУсловия.Параметры.СуммаНесчастныйСлучай		= Формат(100000, "ЧДЦ=2");
		
		// Хрусталев Андрей / 07.09.2023 / DEV-232 / Начало
		Если Выборка.СуммаПремии = 4400 Тогда
			ОбластьУсловия.Параметры.ТарифНесчастныйСлучай		= 3.91;
			ОбластьУсловия.Параметры.ПремияНесчастныйСлучай		= Формат(3910, "ЧДЦ=2");
			ОбластьУсловия.Параметры.СуммаКОплате				= Формат(4400, "ЧДЦ=2");
		ИначеЕсли Выборка.СуммаПремии = 5852 Тогда
			ОбластьУсловия.Параметры.ТарифНесчастныйСлучай		= 5.36;
			ОбластьУсловия.Параметры.ПремияНесчастныйСлучай		= Формат(5362, "ЧДЦ=2");
			ОбластьУсловия.Параметры.СуммаКОплате				= Формат(5852, "ЧДЦ=2");
        КонецЕсли;
		// Хрусталев Андрей / 07.09.2023 / DEV-232 / Конец
		
		ОбластьУсловия.Параметры.ЕдиновременноДо			= Формат(Выборка.ДатаНачала, "ДФ=dd.MM.yyyy");
		ОбластьУсловия.Параметры.ВидОплаты					= "Наличные";
		ОбластьУсловия.Параметры.ДатаОплаты 				= Формат(Выборка.ДатаНачала, "ДФ=dd.MM.yyyy");
		
		ТабличныйДокумент.Вывести(ОбластьУсловия);

		ОбластьПодвал										= Макет.ПолучитьОбласть("Подвал");
		
		ТабличныйДокумент.Вывести(ОбластьПодвал);
			
	КонецЕсли;
	
	Возврат ТабличныйДокумент;
	
КонецФункции

Функция ПолучитьПечатнуюФорму_НадежнаяПоездкаПлюс(ОбъектНазначения) Экспорт 
	
	ТабличныйДокумент = Новый ТабличныйДокумент;
	
	Запрос = Новый Запрос;
	Запрос.Текст =
	"ВЫБРАТЬ
	|	НастройкиСтраховыхПродуктовСрезПоследних.СуммаПремии КАК СуммаПремии,
	|	НастройкиСтраховыхПродуктовСрезПоследних.СтраховойПродукт КАК СтраховойПродукт,
	|	НастройкиСтраховыхПродуктовСрезПоследних.КраткоеОписание КАК КраткоеОписание,
	|	НастройкиСтраховыхПродуктовСрезПоследних.НазваниеПрограммы КАК НазваниеПрограммы
	|ПОМЕСТИТЬ ВТ_НастройкиСтраховыхПродуктов
	|ИЗ
	|	РегистрСведений.НастройкиСтраховыхПродуктов.СрезПоследних(, СтраховойПродукт = &СтраховойПродукт) КАК НастройкиСтраховыхПродуктовСрезПоследних
	|;
	|
	|////////////////////////////////////////////////////////////////////////////////
	|ВЫБРАТЬ
	|	ДоговорыСтрахованияДВС.СтраховойПродукт КАК СтраховойПродукт,
	|	ДоговорыСтрахованияДВС.Страхователь КАК Страхователь,
	|	СертификатыСтраховыхПрограмм.НомерСертификата КАК НомерСертификата,
	|	СертификатыСтраховыхПрограмм.КодАктивации КАК КодАктивации,
	|	ДоговорыСтрахованияДВС.ДатаНачала КАК ДатаНачала,
	|	ДоговорыСтрахованияДВС.СуммаПремии КАК СуммаПремии,
	|	ВТ_НастройкиСтраховыхПродуктов.КраткоеОписание КАК КраткоеОписание,
	|	ВЫБОР
	|		КОГДА ДоговорСтрахования.ТранспортноеСредство_Марка = """"
	|			ТОГДА ""Отсутствует""
	|		ИНАЧЕ ДоговорСтрахования.ТранспортноеСредство_Марка
	|	КОНЕЦ КАК Марка,
	|	ВЫБОР
	|		КОГДА ДоговорСтрахования.ТранспортноеСредство_Модель = """"
	|			ТОГДА ""Отсутствует""
	|		ИНАЧЕ ДоговорСтрахования.ТранспортноеСредство_Модель
	|	КОНЕЦ КАК Модель,
	|	ВЫБОР
	|		КОГДА ДоговорСтрахования.ТранспортноеСредство_VIN = """"
	|			ТОГДА ""Отсутствует""
	|		ИНАЧЕ ДоговорСтрахования.ТранспортноеСредство_VIN
	|	КОНЕЦ КАК VIN,
	|	ВЫБОР
	|		КОГДА ДоговорСтрахования.ТранспортноеСредство_НомерКузова = """"
	|			ТОГДА ""Отсутствует""
	|		ИНАЧЕ ДоговорСтрахования.ТранспортноеСредство_НомерКузова
	|	КОНЕЦ КАК НомерКузова,
	|	ВЫБОР
	|		КОГДА ДоговорСтрахования.ТранспортноеСредство_ГРН = """"
	|			ТОГДА ""Отсутствует""
	|		ИНАЧЕ ДоговорСтрахования.ТранспортноеСредство_ГРН
	|	КОНЕЦ КАК ГРН,
	|	ДоговорыСтрахованияДВС.Дата КАК ДатаОформления,
	|	ВТ_НастройкиСтраховыхПродуктов.НазваниеПрограммы КАК НазваниеПрограммы
	|ИЗ
	|	Документ.ДоговорСтрахованияДВС КАК ДоговорыСтрахованияДВС
	|		ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрСведений.СертификатыСтраховыхПрограмм КАК СертификатыСтраховыхПрограмм
	|			ВНУТРЕННЕЕ СОЕДИНЕНИЕ ВТ_НастройкиСтраховыхПродуктов КАК ВТ_НастройкиСтраховыхПродуктов
	|			ПО СертификатыСтраховыхПрограмм.СтраховойПродукт = ВТ_НастройкиСтраховыхПродуктов.СтраховойПродукт
	|				И СертификатыСтраховыхПрограмм.СуммаПремии = ВТ_НастройкиСтраховыхПродуктов.СуммаПремии
	|				И СертификатыСтраховыхПрограмм.НазваниеПрограммы = ВТ_НастройкиСтраховыхПродуктов.НазваниеПрограммы
	|		ПО ДоговорыСтрахованияДВС.Ссылка = СертификатыСтраховыхПрограмм.ДоговорСтрахованияДВС
	|			И ДоговорыСтрахованияДВС.СтраховойПродукт = СертификатыСтраховыхПрограмм.СтраховойПродукт
	|			И ДоговорыСтрахованияДВС.НазваниеПрограммы = СертификатыСтраховыхПрограмм.НазваниеПрограммы
	|		ЛЕВОЕ СОЕДИНЕНИЕ Документ.ДоговорСтрахованияОСАГО КАК ДоговорСтрахования
	|		ПО ДоговорыСтрахованияДВС.ДоговорСтрахованияОСАГО = ДоговорСтрахования.Ссылка
	|ГДЕ
	|	ДоговорыСтрахованияДВС.Ссылка = &Ссылка
	|
	|УПОРЯДОЧИТЬ ПО
	|	СуммаПремии";

	СтраховойПродукт = Справочники.СтраховыеПродукты.НадежнаяПоездкаПлюс;
	
	//Если ЗначениеЗаполнено(ЭтотОбъект.НазваниеПрограммы) Тогда
	//	
	//	НазваниеПрограммы = ЭтотОбъект.НазваниеПрограммы;
	//	Запрос.УстановитьПараметр("НазваниеПрограммы", НазваниеПрограммы);
	//	
	//	ТекстЗапроса = СтрЗаменить(ТекстЗапроса, "//&НазваниеПрограммы", "И НазваниеПрограммы = &НазваниеПрограммы");
	//	Запрос.Текст = ТекстЗапроса;
	//	
	//Иначе
	//	Запрос.Текст = ТекстЗапроса;
	//КонецЕсли;
	
	Запрос.УстановитьПараметр("СтраховойПродукт", СтраховойПродукт);
	Запрос.УстановитьПараметр("Ссылка", ОбъектНазначения);
	
	РезультатЗапроса = Запрос.Выполнить();
	Выборка = РезультатЗапроса.Выбрать();
	
	Если Выборка.Следующий() Тогда
		
		Макет = ПолучитьМакет("НадежнаяПоездкаПлюс");
		
		ОбластьШапка 	= Макет.ПолучитьОбласть("Шапка");
		ОбластьУслуга 	= Макет.ПолучитьОбласть("Услуга");
		ОбластьУслуги 	= Макет.ПолучитьОбласть("Услуги");
		ОбластьПодвал 	= Макет.ПолучитьОбласть("Подвал");
		
		СтраховойПакет 	= ОпределитьСтраховойПакет(Выборка.СуммаПремии, СтраховойПродукт);
		СтраховойПакет 	= СокрЛП(СтраховойПакет);
		МассивСтрок 	= СтрРазделить(СтраховойПакет, Символы.ПС, Ложь);
		СтраховойПакет	= СтрСоединить(МассивСтрок, Символы.ПС);
		
		//ОбластьШапка.Параметры.СтраховойПакет		= СтраховойПакет;
		ОбластьШапка.Параметры.ФИОВладельца			= Выборка.Страхователь;
		ОбластьШапка.Параметры.НомерСертификата		= Выборка.НомерСертификата;
		
		ТабличныйДокумент.Вывести(ОбластьШапка);
		
		// Хрусталев Андрей / 16.10.2023 13:41:30 / DEV-487 / начало
		НастройкиСтраховыхПрограмм = РегистрыСведений.НастройкиСтраховыхПрограмм.ПолучитьНастройкиСраховыхПрограмм(СтраховойПродукт, Выборка.СуммаПремии, Выборка.НазваниеПрограммы);
		// Хрусталев Андрей / 16.10.2023 13:41:30 / DEV-487 / конец
		
		КоличествоУслуг = 0;
		ВысотаТаблицы 	= ТабличныйДокумент.ВысотаТаблицы;
		
		Для Каждого СтрокаНастройка Из НастройкиСтраховыхПрограмм Цикл
			
			Если СтрокаНастройка.ЗначениеНастройки <> "" Тогда
				
				Если КоличествоУслуг = 0 Тогда
					
					//СуммаПоРискам = НайтиСтраховуюСуммуПоРискам(Выборка.СуммаПремии, Выборка.СтраховойПродукт);
					
					СтрокаСуммаПоРискам = НастройкиСтраховыхПрограмм.Найти(ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.СтраховаяСуммаПоРискам_НадежнаяПоездкаПлюс, "ВидНастройки");
					Если СтрокаСуммаПоРискам = Неопределено Тогда
						Возврат Неопределено;
					КонецЕсли;  
					
					СуммаПоРискам = СтрокаСуммаПоРискам.ЗначениеНастройки;
					
					ОбластьУслуга.Параметры.Описание = СтрШаблон("Страхование действует в отношении транспортного средства: Марка - %1, Модель - %2, VIN - %3, No кузова - %4, , гос. номер - %5 
						|Количество посадочных мест не более 5-ти.
						|Страховая сумма установлена «по паушальной системе»* – %6 руб.
						|Водители и пассажиры застрахованы по рискам: 
						|1.   «Смерть в результате несчастного случая», 
						|2.   «Инвалидность в результате несчастного случая», 
						|3.   «Телесные повреждения в результате несчастного случая».;
						|
						|Срок страхования: по рискам «Смерть в результате несчастного случая», «Инвалидность в результате 
						|несчастного случая» и «Телесные повреждения в результате несчастного случая» - 12 месяцев 
						|с даты начала срока страхования.", Выборка.Марка, Выборка.Модель, Выборка.VIN, Выборка.НомерКузова, Выборка.ГРН, СуммаПоРискам);	
					
					ТабличныйДокумент.Вывести(ОбластьУслуга);
						
					КоличествоУслуг = КоличествоУслуг + 1
					
				КонецЕсли;
				
				Если СтрокаНастройка.ВидНастройки = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.БесплатныйНомерДляОбращенияЗаУслугой_НадежнаяПоездкаПлюс Тогда
					ОбластьУслуги.Параметры.ОписаниеУслуги = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.БесплатныйНомерДляОбращенияЗаУслугой_НадежнаяПоездкаПлюс.Наименование;
				ИначеЕсли СтрокаНастройка.ВидНастройки = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.ПодборСтраховойКомпании_НадежнаяПоездкаПлюс Тогда
					ОбластьУслуги.Параметры.ОписаниеУслуги = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.ПодборСтраховойКомпании_НадежнаяПоездкаПлюс.Наименование;
				ИначеЕсли СтрокаНастройка.ВидНастройки = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.УстнаяКонсультация_НадежнаяПоездкаПлюс Тогда
					ОбластьУслуги.Параметры.ОписаниеУслуги = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.УстнаяКонсультация_НадежнаяПоездкаПлюс.Наименование;
				ИначеЕсли СтрокаНастройка.ВидНастройки = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.ПодготовкаДокументов_НадежнаяПоездкаПлюс Тогда
					ОбластьУслуги.Параметры.ОписаниеУслуги = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.ПодготовкаДокументов_НадежнаяПоездкаПлюс.Наименование;
				ИначеЕсли СтрокаНастройка.ВидНастройки = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.ПредоставлениеТиповыхФормДокументов_НадежнаяПоездкаПлюс Тогда
					ОбластьУслуги.Параметры.ОписаниеУслуги = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.ПредоставлениеТиповыхФормДокументов_НадежнаяПоездкаПлюс.Наименование;
				ИначеЕсли СтрокаНастройка.ВидНастройки = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.УстнаяКонсультацияПоУрегулированиюСтраховогоСлучая_НадежнаяПоездкаПлюс Тогда
					ОбластьУслуги.Параметры.ОписаниеУслуги = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.УстнаяКонсультацияПоУрегулированиюСтраховогоСлучая_НадежнаяПоездкаПлюс.Наименование;
				ИначеЕсли СтрокаНастройка.ВидНастройки = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.ПодборЭкспертныхКомпаний Тогда
					ОбластьУслуги.Параметры.ОписаниеУслуги = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.ПодборЭкспертныхКомпаний.Наименование;
				ИначеЕсли СтрокаНастройка.ВидНастройки = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.ПодготовкаДокументовДляУрегулированияСтраховогоСлучая_НадежнаяПоездкаПлюс Тогда
					ОбластьУслуги.Параметры.ОписаниеУслуги = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.ПодготовкаДокументовДляУрегулированияСтраховогоСлучая_НадежнаяПоездкаПлюс.Наименование; 
				ИначеЕсли СтрокаНастройка.ВидНастройки = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.ПредоставлениеТиповыхФормДокументовПоУрегулированиюСтраховогоСлучая_НадежнаяПоездкаПлюс Тогда
					ОбластьУслуги.Параметры.ОписаниеУслуги = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.ПредоставлениеТиповыхФормДокументовПоУрегулированиюСтраховогоСлучая_НадежнаяПоездкаПлюс.Наименование;
				//ИначеЕсли СтрокаНастройка.ВидНастройки = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.УслугаПоПрисоединениюККоллективномуДоговору_НадежнаяПоездкаПлюс Тогда
				//	 ОбластьУслуги.Параметры.ОписаниеУслуги = ПланыВидовХарактеристик.НастройкиСтраховыхПрограмм.УслугаПоПрисоединениюККоллективномуДоговору_НадежнаяПоездкаПлюс.Наименование;
				Иначе
					Продолжить;	
				КонецЕсли;
				
				ОбластьУслуги.Параметры.ОбъемУслуги = СтрокаНастройка.ЗначениеНастройки;
				
				ОбластьУслуги.Параметры.ТекстУслуги = "Консультационно - информационные услуги";
				
				ТабличныйДокумент.Вывести(ОбластьУслуги); 
				
				КоличествоУслуг = КоличествоУслуг + 1;
				
			КонецЕсли;
			
		КонецЦикла;
		
		ОбъединениеНачало = 12; 
		
		Для НомерСтроки = 12 По 12 + КоличествоУслуг Цикл  
			
			Если ТабличныйДокумент.Область(НомерСтроки, 2, НомерСтроки,2).Текст = ТабличныйДокумент.Область((НомерСтроки - 1), 2, (НомерСтроки - 1), 2).Текст Или ОбъединениеНачало = НомерСтроки Тогда
				Продолжить;
			Иначе
				ТабличныйДокумент.Область(ОбъединениеНачало, 2, НомерСтроки - 1, 2).Объединить();
				ОбъединениеНачало = НомерСтроки;
			КонецЕсли;   
			
		КонецЦикла;  
				
		ОбластьПодвал.Параметры.ДатаОформления	= Формат(Выборка.ДатаОформления, "ДЛФ=Д");
		ОбластьПодвал.Параметры.СтоимостьУслуг 	= Выборка.СуммаПремии;
		
		ТабличныйДокумент.Вывести(ОбластьПодвал);
		
	КонецЕсли;
	
	Возврат ТабличныйДокумент;
	
КонецФункции

Leave a Comment